appui-react
Classes
Name | Description | |
---|---|---|
AccuDrawCommandItems | AccuDraw Command Items - useful in Keyboard Shortcuts | Deprecated |
AccuDrawGrabInputFocusEvent | AccuDraw Grab Input Focus event | Deprecated |
AccuDrawKeyboardShortcuts | Default AccuDraw Keyboard Shortcuts | |
AccuDrawPopupManager | AccuDraw Popup Manager class | |
AccuDrawSetCompassModeEvent | AccuDraw Set Compass Mode event | Deprecated |
AccuDrawSetFieldFocusEvent | AccuDraw Set Field Focus event | Deprecated |
AccuDrawSetFieldLockEvent | AccuDraw Set Field Lock event | Deprecated |
AccuDrawSetFieldValueFromUiEvent | AccuDraw Set Field Value from Ui event | Deprecated |
AccuDrawSetFieldValueToUiEvent | AccuDraw Set Field Value to Ui event | Deprecated |
AccuDrawUiSettingsChangedEvent | AccuDraw Ui Settings Changed event | Deprecated |
AccuDrawWidgetControl | AccuDraw Widget Control | Deprecated |
ActionButtonItemDef | Abstract base class that is used by classes to execute an action when pressed. | Deprecated |
ActiveContentChangedEvent | Active Content Changed Event class. | Deprecated |
Activity Message Cancelled Event class. | Deprecated | |
Activity Message Added Event class. | Deprecated | |
AnalysisAnimationTimelineDataProvider | Analysis Timeline Data Provider - Allows a TimelineComponent to animate the AnalysisStyle information stored in a ViewState. | |
AppNotificationManager | Subclass of NotificationManager in @itwin/core-frontend to be used to initialize IModelApp . |
|
AppUiSettings | These are the UI settings that are stored in the Redux store. | Deprecated |
BackstageManager | Controls backstage. | Deprecated |
BaseUiItemsProvider | Base implementation of a UiItemsProvider. | Deprecated |
Calculator | ||
CalculatorPopup | Popup component for Calculator | Deprecated |
CardPopup | Popup component for Input Editor | |
CommandItemDef | An Item that executes a Command. | Deprecated |
ConfigurableBase | The base class for all ConfigurableUi elements | Deprecated |
ConfigurableCreateInfo | Information for creating a ConfigurableUi element | Deprecated |
ConfigurableUiControl | The abstract base class for all Frontstage controls. | Deprecated |
ContentControl | The base class for Frontstage content controls. | Deprecated |
ContentControlActivatedEvent | ContentControl Activated Event class. | Deprecated |
ContentDialogChangedEvent | Content Dialog Changed Event class. | Deprecated |
ContentDialogRenderer | ContentDialogRenderer React component renders modeless dialogs. | |
ContentGroup | ContentGroup class. | |
ContentGroupProvider | Abstract class that can be implemented and specified by frontstage to dynamically construct | |
ContentLayoutActivatedEvent | Content Layout Activated Event class. | Deprecated |
ContentLayoutDef | Content Layout Definition class. | |
CoreTools | Utility Class that provides definitions of tools provided by the core-frontend core. | Deprecated |
CubeNavigationAidControl | Navigation Aid that displays an interactive rotation cube for Spatial views that synchronizes with the rotation of the iModel Viewport | Deprecated |
CursorInformation | Cursor Information class | |
CursorPopup | CursorPopup React component | |
CursorPopupManager | CursorPopup component | |
CursorPopupRenderer | CursorPopupRenderer React component. | |
CursorUpdatedEvent | Cursor Updated Event class. | Deprecated |
CustomItemDef | An Item that renders a React component. | Deprecated |
DialogChangedEvent | Dialog Changed Event class. | Deprecated |
DrawingNavigationAidControl | Navigation Aid that displays an interactive mini-map for Drawing views that synchronizes with the iModel Viewport. | Deprecated |
ElementTooltip | ElementTooltip React component. | |
ElementTooltipChangedEvent | ElementTooltip Changed Event class. | Deprecated |
ExpandableSection | Expandable Section React component | |
FloatingContentControl | Deprecated | |
FloatingViewportContentControl | Deprecated | |
FrameworkAccuDraw | Subclass of AccuDraw in @itwin/core-frontend to be used to initialize IModelApp . |
|
FrameworkToolAdmin | Subclass of ToolAdmin in @itwin/core-frontend to be used to initialize IModelApp . |
|
FrameworkUiAdmin | Subclass of UiAdmin in @itwin/core-frontend to be used to initialize IModelApp . |
|
FrontstageActivatedEvent | Frontstage Activated Event class. | Deprecated |
FrontstageDeactivatedEvent | Frontstage Deactivated Event class. | Deprecated |
FrontstageDef | FrontstageDef class provides an API for a Frontstage. | |
FrontstageProvider | Provides a definition required to create a Frontstage. | Deprecated |
FrontstageReadyEvent | Frontstage Ready Event class. | Deprecated |
GroupItemDef | An Item that opens a group of items. | Deprecated |
HideIsolateEmphasizeActionHandler | Interface for class that handles Hide, Isolate, and Emphasize Actions | |
HideIsolateEmphasizeManager | Provides helper functions for doing commands on logical selection like categories and subjects. | |
IModelViewportControl | iModel Viewport Control | Deprecated |
InputEditorCommitHandler | ||
InputField message pops up near pointer when attempting an invalid interaction. | Deprecated | |
Input Field Message Added Event class | Deprecated | |
Input Field Message Removed Event class. | Deprecated | |
ItemDefBase | The base class for Items. | Deprecated |
ItemList | Contains a list of Items. | Deprecated |
ItemMap | Contains a map of Items. | Deprecated |
KeyboardShortcut | Keyboard Shortcut used to execute an action | Deprecated |
KeyboardShortcutContainer | Keyboard Shortcut Container | Deprecated |
KeyboardShortcutMenu | React component that displays a context menu at the cursor containing keyboard shortcuts. | Deprecated |
KeyboardShortcutMenuEvent | KeyboardShortcut Menu Event class. | Deprecated |
ListPicker | List Picker that lets the user pick from a list of items to enable/disable | |
ListPickerItem | List Picker Item React component | |
MenuButton | ||
MenuButtonPopup | Popup component for Menu Buttons | |
Message Added Event class. | Deprecated | |
The MessageManager class manages messages and prompts. | ||
Messages Updated Event class. | Deprecated | |
ModalDialogChangedEvent | Modal Dialog Changed Event class. | Deprecated |
ModalDialogRenderer | ModalDialogRenderer React component renders modal dialogs | |
ModalFrontstage | ModalFrontstage React component | |
ModalFrontstageChangedEvent | Modal Frontstage Stack Changed Event class. | Deprecated |
ModalFrontstageClosedEvent | Modal Frontstage Closed Event class. | Deprecated |
ModelessDialog | Modeless Dialog React component uses the Dialog component with a modal={false} prop. | Deprecated |
ModelessDialogChangedEvent | Modeless Dialog Changed Event class. | Deprecated |
ModelessDialogRenderer | ModelessDialogRenderer React component renders modeless dialogs. | |
MouseDownChangedEvent | Mouse Down Changed Event class. | Deprecated |
NavigationAidActivatedEvent | NavigationAid Activated Event class. | Deprecated |
NavigationAidControl | The base class for Navigation Aid controls. | Deprecated |
NestedFrontstage | Nested Frontstage related classes and commands | Deprecated |
Open Message Center Event class. | Deprecated | |
PanelStateChangedEvent | Panel state changed event class. | Deprecated |
Pointer message pops up near pointer when attempting an invalid interaction. | ||
Pointer Message Changed Event emitted by the PointerMessage component | Deprecated | |
PopupManager | Popup Manager class | |
PopupRenderer | Popup Renderer. | |
PopupsChangedEvent | Popups Changed Event class. | Deprecated |
PositionPopup | Popup component at screen position | |
PropsHelper | A set of helper methods for various props | Deprecated |
Describes a message to be displayed to the user and adds support for React components in messages. | ||
ReducerRegistry | Redux Reducer Registry. | Deprecated |
RestoreAllFrontstagesTool | Immediate tool that will reset the layout of all frontstages to that specified in the stage definition. | |
RestoreFrontstageLayoutTool | Immediate tool that will reset the layout to that specified in the stage definition. | |
ScheduleAnimationTimelineDataProvider | ScheduleAnimation Timeline Data Provider - allows a TimelineComponent to animate the data found in a ScheduleScript in a ViewState. | |
SelectionContextToolDefinitions | Utility Class that provides definitions for tools dependent on current selection. | Deprecated |
SettingsModalFrontstage | Modal frontstage displaying and editing settings from registered settings providers. | |
SheetNavigationAid | A Sheet Navigation Aid. | |
SheetNavigationAidControl | A Sheet Navigation Aid control. | Deprecated |
StageContentLayout | StageContentLayout class. | |
StagePanelDef | A StagePanelDef represents each Stage Panel within a Frontstage. | |
StandardContentLayouts | Class that define Standard Content Layouts that can be used to specify how the content is arranged in a frontstage. | |
StandardContentToolsProvider | Provide standard tools for the ContentManipulationWidgetComposer. | Deprecated |
StandardContentToolsUiItemsProvider | Provides standard content manipulation items. | |
StandardFrontstageProvider | FrontstageProvider that provides an "empty" stage. | Deprecated |
StandardNavigationToolsProvider | Provide standard tools for the ViewNavigationWidgetComposer. | Deprecated |
StandardNavigationToolsUiItemsProvider | Provide standard view navigation items. | |
StandardRotationNavigationAid | A 3D Standard Rotation Navigation Aid. | |
StandardRotationNavigationAidControl | A 3D Standard Rotation Navigation Aid control. | Deprecated |
StandardStatusbarItemsProvider | Provide standard status bar fields. | Deprecated |
StandardStatusbarUiItemsProvider | Provides standard status bar items. | |
StateManager | Centralized state management class using Redux actions, reducers and store. | Deprecated |
StatusBarWidgetComposerControl | StatusBarWidgetComposerControl provides status bar to specified Frontstage that allows status bar items to be populated | Deprecated |
StatusBarWidgetControl | Status Bar Widget Control. | Deprecated |
SyncToolSettingsPropertiesEvent | Sync Tool Settings Properties Event class. | Deprecated |
SyncUiEventDispatcher | This class is used to send eventIds to interested UI components so the component can determine if it needs | |
TileLoadingIndicator | TileLoadingIndicator React component | |
ToolActivatedEvent | Tool Activated Event class. | Deprecated |
ToolAssistanceChangedEvent | Tool Assistance Changed event class | Deprecated |
ToolAssistanceField | Tool Assistance Field React component. | |
ToolbarButtonHelper | A set of Dom helper methods | |
ToolbarHelper | Helper functions for defining a Toolbar items used in Toolbar , ToolbarComposer and UiItemsProvider . |
Deprecated |
ToolbarPopup | Popup component for Toolbar | |
ToolIconChangedEvent | Tool Icon Changed Event class. | Deprecated |
ToolInformation | Provides information about a tool with a given id, including the ToolUiProvider. | Deprecated |
ToolItemDef | An Item that starts the execution of a Tool. | Deprecated |
ToolSettingsPopup | Popup component for Tool Settings | |
ToolUiProvider | ToolUiProvider provides the Tool Settings and/or Tool Assistance UI for a tool. | Deprecated |
UiFramework | Main entry point to configure and interact with the features provided by the AppUi-react package. | |
UiItemsManager | Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface. | |
UiSyncEvent | UiSync Event class. | Deprecated |
UiVisibilityChangedEvent | UiVisibility Event class. | Deprecated |
ViewAttributesStatusField | Widget for showing Checkboxes for View Attributes | |
ViewportContentControl | The base class for frontstage Viewport content controls that connects to a ScreenViewport |
Deprecated |
ViewSelector | View Selector React component | |
ViewSelectorChangedEvent | ViewSelector Changed Event class. | Deprecated |
ViewStateHelper | SavedView class. | |
ViewUtilities | Various View utility methods | |
WidgetControl | The base class for Widget controls. | Deprecated |
WidgetDef | A Widget Definition in the 9-Zone Layout system. | |
WidgetHost | A WidgetHost represents a definition that hosts one or most Widgets in a Frontstage. | |
WidgetManager | Widget Manager class. | |
WidgetStateChangedEvent | Widget State Changed Event class. | Deprecated |
Constants
Name | Description | |
---|---|---|
ConditionalBooleanValue | ||
ConditionalStringValue | ||
ConfigurableUiActions | An object with a function that creates each ConfigurableUiReducer that can be handled by our reducer. | Deprecated |
LocalStateStorage | ||
ReducerRegistryInstance | ReducerRegistryInstance singleton instance of Reducer Registry | Deprecated |
SafeAreaContext | Context used to manage safe area (feature used by devices with non-rectangular screens). | |
SessionStateActions | An object with a function that creates each SessionStateReducer that can be handled by our reducer. | Deprecated |
sessionStateMapDispatchToProps | Object that contains available actions that modify SessionState. | Deprecated |
SettingsManager | ||
SYSTEM_PREFERRED_COLOR_THEME | System preferred color theme. | |
TOOLBAR_OPACITY_DEFAULT | The default widget opacity. | |
ToolbarDragInteractionContext | Context used to enable toolbar drag interaction. | |
UiStateStorageStatus | ||
WIDGET_OPACITY_DEFAULT | The default widget opacity. |
Enumerations
Name | Description | |
---|---|---|
ColorTheme | Enum for the Color Theme string. | |
ConfigurableUiActionId | Action Ids used by Redux and to send sync UI components. | Deprecated |
ConfigurableUiControlType | The type of the ConfigurableUiControl. | Deprecated |
CursorDirection | Enum for Cursor Direction | |
CursorDirectionParts | Enum for Cursor Direction parts | |
HideIsolateEmphasizeAction | Supported Hide, Isolate, and Emphasize Actions. | |
KeyinFieldLocalization | Controls whether localized and/or non-localized key-in strings appear in a KeyinField's auto-completion list. | |
ListItemType | Enum for the list picker item type | |
SafeAreaInsets | Describes available safe area insets. | |
SelectionScope | Selection Scope enum. | |
SessionStateActionId | Action Ids used by Redux and to send sync UI components. | Deprecated |
StagePanelLocation | Available Stage Panel locations. | |
StagePanelSection | Enum for Stage Panel Sections | |
StagePanelState | Enum for StagePanel state. | |
StageUsage | Standard stage uses. | |
StatusBarLabelSide | Defines which side of Icon where label is placed | |
StatusBarSection | Status bar Groups/Sections from Left to Right | |
SyncUiEventId | Event Id used to sync UI components. | |
ToolbarOrientation | Used to specify the orientation of the toolbar. | |
ToolbarUsage | Used to specify the usage of the toolbar which determine the toolbar position. | |
WidgetState | Widget state enum. | |
WidgetType | Widget type enum. |
Global Functions
Name | Description | |
---|---|---|
AccuDrawDialog | Dialog displays AccuDrawFieldContainer for AccuDraw Ui | |
AccuDrawFieldContainer | AccuDraw Ui Field Container displays AccuDrawInputField for each field | |
AccuDrawInputField | Input field for AccuDraw UI. | |
AccuDrawWidget | AccuDraw Widget displays AccuDrawFieldContainer for AccuDraw Ui | |
ActivityCenterField | Activity Center Field React component. | |
areNoFeatureOverridesActive | Return ConditionalBooleanValue object used to show items if selection set is active. | Deprecated |
BackstageAppButton | Component shown in the top-left corner of the content manipulation area. | |
BackstageComposer | Backstage component composed from backstage items. | |
BasicNavigationWidget | Basic Navigation Widget that provides standard tools to manipulate views containing element data. | |
BasicToolWidget | Default Tool Widget for standard "review" applications. | |
Card | Card component | |
combineReducers | Turns an object whose values are different reducer functions, into a single | Deprecated |
ConfigurableUiContent | The ConfigurableUiContent component is the component the pages specified using ConfigurableUi | |
ConfigurableUiReducer | Handles actions to update ConfigurableUiState. | Deprecated |
connectIModelConnection | Function that will connect a component to the IModelConnection data in the Redux store. | Deprecated |
connectIModelConnectionAndViewState | Function that will connect a component to the IModelConnection data in the Redux store | Deprecated |
ContentDialog | Content Dialog React component uses the Dialog component with a modal={false} prop. | Deprecated |
ContentLayout | Content Layout React component. | |
ContentOverlay | Overlay used to identify active content views. | |
ContentToolWidgetComposer | ContentToolWidgetComposer composes a Tool Widget with no tools defined by default. | |
createAction | Creates a basic Redux Redux Action with a payload value. | Deprecated |
CursorPopupContent | CursorPopup content with padding | |
DefaultDialogGridContainer | DefaultDialogGridContainer populates a React node with the items specified by the UiLayoutDataProvider | |
DefaultViewOverlay | Default viewport overlay that examines ViewState of the active view for a schedule script, analysis data, or solar data. | |
featureOverridesActiveStateFunc | Return state with isVisible set to true is SectionSet is active. | Deprecated |
FloatingViewportContent | Deprecated | |
FloatingViewportContentWrapper | Deprecated | |
FrameworkReducer | Framework reducer that combines the ConfigurableUiReducer and SessionStateReducer. | Deprecated |
getFeatureOverrideSyncEventIds | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
getIsHiddenIfFeatureOverridesActive | Return ConditionalBooleanValue object used to show item if feature overrides are active. | Deprecated |
getIsHiddenIfSelectionNotActive | Return ConditionalBooleanValue object used to show items if selection set is active. | Deprecated |
getListPanel | ||
getQuantityFormatsSettingsManagerEntry | Return a SettingsTabEntry that can be used to define the available settings that can be set for an application. | |
getSelectionContextSyncEventIds | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
getUiSettingsManagerEntry | Return a SettingsTabEntry that can be used to define the available settings that can be set for an application. | |
IModelConnectedViewport | Viewport that is connected to the IModelConnection property in the Redux store. | Deprecated |
IModelConnectedViewSelector | ViewSelector that is connected to the IModelConnection property in the Redux store. | Deprecated |
isBackstageActionItem | BackstageActionItem type guard. | |
isBackstageStageLauncher | BackstageStageLauncher type guard. | |
isNoSelectionActive | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
isStatusBarActionItem | StatusBarActionItem type guard. | |
isStatusBarCustomItem | StatusBarCustomItem type guard. | |
isStatusBarLabelItem | StatusBarLabelItem type guard. | |
isToolbarActionItem | ToolbarActionItem type guard. | |
isToolbarCustomItem | ToolbarCustomItem type guard. | |
isToolbarGroupItem | ToolbarGroupItem type guard. | |
KeyinPalettePopup | Keyin Palette Popup Component | |
Message Center Field React component. | ||
NavigationAidHost | Component that is used as a default navigation aid. | |
NavigationWidgetComposer | Component that Composes a NavigationWidget typically using toolbars generated via ToolbarComposer class. | |
NestedFrontstageAppButton | App button used in a nested frontstage. | |
PositionPopupContent | PositionPopup content with padding | |
PreviewFeaturesProvider | Set which preview features are enabled. | |
QuantityFormatSettingsPage | UI Component shown in settings page to set the active Presentation Unit System and to set format overrides. | |
SectionsStatusField | Status Field for showing section extra tools for clearing and showing manipulators | |
selectionContextStateFunc | Return state with isVisible set to true is SectionSet is active. | Deprecated |
SelectionCountField | Status field component used to display the number of selected items. | |
SelectionInfoField | SelectionInfoField component is designed to be specified in a status bar. |
Deprecated |
SelectionScopeField | SelectionScopeField component is designed to be specified in a status bar. |
|
SessionStateReducer | Handles actions to update SessionState. | Deprecated |
SnapModeField | SnapModeField component designed to be specified in a status bar. |
|
SplitPane | Local TypeScript implementation of SplitPane from react-split-pane package since that |
|
StandardMessageBox React component displays a standard icon, message text and a standard button set in the lower right. | Deprecated | |
StatusBar | Status Bar React component. | Deprecated |
StatusBarCenterSection | StatusBar Center Section React functional component | |
StatusBarComposer | Component to load components into the StatusBar. | |
StatusBarDialog | Dialog component used in a StatusBarIndicator component. | |
StatusBarDialogTitleBar | Dialog component used in a StatusBarDialog component. | |
StatusBarDialogTitleBarButton | Dialog component used in a StatusBarDialog component. | |
StatusBarField | Field component used in StatusBar component. | Deprecated |
StatusBarIndicator | General-purpose StatusBar indicator. | Deprecated |
StatusBarLabelIndicator | StatusBar indicator that shows a label with an icon. | Deprecated |
StatusBarLeftSection | StatusBar Left Section React functional component | |
StatusBarPopover | Popover component used in StatusBar component. |
|
StatusBarPopup | Popup component used in StatusBar component. | Deprecated |
StatusBarRightSection | StatusBar Right Section React functional component | |
StatusBarSeparator | Component used to separate status fields in a status bar. | |
StatusBarSpaceBetween | StatusBar With Space Between Items React functional component | |
ThemeManager | ThemeManager handles setting color themes. |
|
Toolbar | Component that displays toolbar items. | |
ToolbarComposer | Toolbar that is populated and maintained by UI item providers. | |
ToolbarWithOverflow | Component that displays toolbar items, displaying only the elements that can fit in the available space, | |
ToolSettingsGridContainer | Component to provide grid of property editors | |
ToolWidgetComposer | ToolWidget component that supports use of ToolbarComposer-based Toolbars. | |
UiDataProvidedDialog | Component to show dialog populated from properties supplied via uiDataProvider | Deprecated |
UiSettingsPage | UiSettingsPage displaying the active UI settings. | Deprecated |
UiStateStorageHandler | Allows to provide a custom UiStateStorage implementation to persist UI settings | |
useActiveFrontstageDef | Hook to return the active Frontstage def. | |
useActiveFrontstageId | Hook that returns active frontstage id. | |
useActiveIModelConnection | React hook that maintains the active IModelConnection. | |
useActiveStageId | React hook that maintains the active stage Id. | |
useActiveViewport | React hook that maintains the active viewport. | |
useAnalysisAnimationDataProvider | Hook that returns either a AnalysisAnimationTimelineDataProvider or undefined based on if the supplied viewport contains analysis data. | |
useBackstageManager | Hook that returns backstage manager. | |
useConditionalValue | Hook that allows to get a value that depends on some sync UI events. | |
useDefaultStatusBarItems | Hook that returns items from StatusBarItemsManager. | Deprecated |
useDefaultToolbarItems | Hook that returns items from ToolbarItemsManager. | Deprecated |
useIsBackstageOpen | Hook that returns isOpen flag of the backstage. | |
useScheduleAnimationDataProvider | Hook that returns either a ScheduleAnimationTimelineDataProvider or undefined based on if the supplied viewport contains schedule script. | |
useSelectionSetSize | React hook that returns element count of a selection set. | |
useSolarDataProvider | Hook that returns either a SolarTimelineDataProvider or undefined based on if the supplied viewport's display style is set to display shadows. | |
useSpecificWidgetDef | Hook that returns the widgetDef for a specific widgetId within the active frontstage. | |
useTransientState | Hook that allows to save and restore transient DOM state (i.e. | |
useUiItemsProviderBackstageItems | Hook that returns backstage items from UiItemsManager. | Deprecated |
useUiItemsProviderStatusBarItems | Hook that returns items from StatusBarItemsManager. | Deprecated |
useUiItemsProviderToolbarItems | Hook that retrieves active frontstage toolbar items from UiItemsProviders and manage them through ToolbarItemsManager. | Deprecated |
useUiStateStorageHandler | ||
ViewToolWidgetComposer | ViewToolWidgetComposer composes a Navigation Widget with no tools defined by default. |
Interfaces
Name | Description | |
---|---|---|
AccuDrawDialogProps | Properties for AccuDrawDialog | Deprecated |
AccuDrawFieldContainerProps | Properties for AccuDrawFieldContainer component | Deprecated |
AccuDrawInputFieldProps | Properties for AccuDrawInputField component | Deprecated |
AccuDrawSetCompassModeEventArgs | Arguments for AccuDrawSetCompassModeEvent | Deprecated |
AccuDrawSetFieldFocusEventArgs | Arguments for AccuDrawSetFieldFocusEvent | Deprecated |
AccuDrawSetFieldLockEventArgs | Arguments for AccuDrawSetFieldLockEvent | Deprecated |
AccuDrawSetFieldValueFromUiEventArgs | Arguments for AccuDrawSetFieldValueFromUiEvent | Deprecated |
AccuDrawSetFieldValueToUiEventArgs | Arguments for AccuDrawSetFieldValueToUiEvent | Deprecated |
AccuDrawUiSettings | AccuDraw User Interface Settings | |
Action | A basic Redux Action. | |
ActionCreatorsObject | Just an object where every property is a Redux Action Creator. | Deprecated |
ActionWithPayload | A Redux Action, with additional "payload" information. | |
ActiveContentChangedEventArgs | ActiveContentChangedEvent Args interface. | Deprecated |
Activity Message Event arguments. | Deprecated | |
AllowedUiItemsProviderOverrides | UiItemsProvider overrides allows the application that registers a provider to limit when it is allowed to provide items | |
BackstageActionItem | Describes the data needed to insert an action button into the backstage menu. | |
BackstageAppButtonProps | Properties of BackstageAppButton component. | |
BackstageComposerProps | Props of BackstageComposer component. | Deprecated |
BackstageStageLauncher | Describes the data needed to insert an action button into the backstage menu. | |
BackstageToggledArgs | Arguments of onToggled. | |
BaseItemState | Base state for any 'stateful' React component. | Deprecated |
BasicNavigationWidgetProps | Properties that can be used to append items to the default set of toolbar items. | Deprecated |
BasicToolWidgetProps | Properties that can be used to append items to the default set of toolbar items. | Deprecated |
CalculatorPopupProps | Deprecated | |
CalculatorProps | ||
CanFloatWidgetOptions | Describes options of a floating widget. | |
CardProps | Props defining a Card component | |
ChildWindowLocationProps | ||
CommandHandler | Definition for a command handler. | Deprecated |
CommandItemProps | Properties for a Command item. | Deprecated |
CommonBackstageItem | Describes the data needed to insert a button into the backstage menu. | |
CommonStatusBarItem | Describes the data needed to insert a button into the status bar. | |
CommonToolbarItem | Describes the data needed to insert a UI items into an existing set of UI items. | |
ConditionalValue | Interface used to track the conditional value of a generic type T . |
|
ConfigurableUiContentProps | Properties for ConfigurableUiContent | Deprecated |
ConfigurableUiElement | Interface for a ConfigurableUi element | Deprecated |
ConfigurableUiState | The portion of state managed by the ConfigurableUiReducer. | Deprecated |
ContentControlActivatedEventArgs | ControlControl Activated Event Args interface. | Deprecated |
ContentDialogInfo | ||
ContentDialogProps | Properties for the ContentDialog component | Deprecated |
ContentGroupProps | Properties for a ContentGroup | |
ContentLayoutActivatedEventArgs | Content Layout Activated Event Args class. | Deprecated |
ContentLayoutComponentProps | Properties for the ContentLayout React component. | |
ContentLayoutProps | Properties for a ContentLayoutDef | |
ContentProps | Properties for content displayed in a content view | |
ContentToolWidgetComposerProps | Props for ContentToolWidgetComposer. | Deprecated |
CursorMenuData | Definition of data added to Redux store to define cursor menu. | Deprecated |
CursorMenuItemProps | Properties for context menu items. | |
CursorMenuPayload | Definition of a cursor menu. | |
CursorPopupOptions | Options for the CursorPopupManager open method | |
CursorUpdatedEventArgs | Cursor Updated Event Args interface. | Deprecated |
CustomItemProps | Definition for a Custom item that renders a React component. | Deprecated |
DefaultContentTools | Defines what tools to include from the provider. | |
DefaultContentToolsAppData | Defines options that may be set in frontstage app data to control what group priorities | Deprecated |
DefaultNavigationTools | Defines what tools to include from the provider. | |
DefaultStatusbarItems | Defines what items to include from the provider. | |
DialogChangedEventArgs | Dialog Stack Changed Event Args class. | Deprecated |
DialogInfo | Information maintained by a Dialog Manager about a dialog | |
ElementTooltipChangedEventArgs | ElementTooltipChangedEvent arguments. | Deprecated |
EmphasizeElementsChangedArgs | Selection Context Action Event Argument | |
ExpandableSectionProps | Properties for the ExpandableSection component | |
ExtensibleToolbarProps | Properties for the ToolbarComposer React components | Deprecated |
FloatingViewportContentProps | Deprecated | |
FloatingViewportContentWrapperProps | Deprecated | |
FrameworkBackstage | backstage interface. | |
FrameworkChildWindows | childWindows interface. | |
FrameworkContent | content interface | |
FrameworkControls | controls interface | Deprecated |
FrameworkDialog | Manages dialog access | |
FrameworkDialogs | dialogs interface. | |
FrameworkFrontstages | frontstages interface | |
FrameworkKeyboardShortcut | Keyboard Shortcut used to execute an action | |
FrameworkKeyboardShortcutContainer | Keyboard Shortcut Container | |
FrameworkKeyboardShortcuts | keyboardShortcuts interface | |
FrameworkRootState | Generic 'root' state for the appui-react package. | Deprecated |
FrameworkStackedDialog | FrameworkDialog that manages the top most content. | |
FrameworkState | Interface combining all the Framework state interfaces. | Deprecated |
FrameworkToolSettings | toolSettings interface | |
FrameworkVisibility | visibility interface | |
FrontstageActivatedEventArgs | Frontstage Activated Event Args interface. | Deprecated |
FrontstageConfig | Configuration from which a frontstage is created. | Deprecated |
FrontstageDeactivatedEventArgs | Frontstage Deactivated Event Args interface. | Deprecated |
FrontstageReadyEventArgs | Frontstage Ready Event Args interface. | Deprecated |
GroupItemProps | Definition for a Group item that opens a group of items. | Deprecated |
IModelViewportControlOptions | IModelViewportControl options. | Deprecated |
InitialAppUiSettings | Default values that may be specified for AppUiSettings. | Deprecated |
InputEditorPopupProps | Props for popup editor | |
Input Field Message Event arguments. | Deprecated | |
ItemProps | Definition that specifies properties shared between many ConfigurableUi components. | Deprecated |
KeyboardShortcutMenuState | State of a KeyboardShortcutMenuEvent and KeyboardShortcutMenu component | Deprecated |
KeyboardShortcutProps | Properties for a Keyboard Shortcut | |
KeyinEntry | Defines a keyin entry to show/filter in UI | |
KeyinPalettePopupProps | Props defining KeyinPalettePopup component | |
LayoutFragmentProps | Properties for a layout fragment | |
LayoutHorizontalSplitProps | Properties for a horizontal layout split | |
LayoutSplitPropsBase | Base interface for layout split properties | |
LayoutVerticalSplitProps | Properties for a vertical layout split. | |
ListItem | List picker item | |
ListPickerItemProps | Properties for the ListPickerItem component | |
ListPickerProps | Properties for the ListPicker component | |
ListPickerPropsExtended | Properties for the ListPicker component | |
MenuButtonPopupProps | ||
MenuButtonProps | ||
MessageAddedEvent arguments. | Deprecated | |
ModalFrontstageChangedEventArgs | Modal Frontstage Changed Event Args interface. | Deprecated |
ModalFrontstageClosedEventArgs | Modal Frontstage Closed Event Args interface. | Deprecated |
ModalFrontstageInfo | Modal Frontstage information interface. | |
ModalFrontstageProps | Properties for the ModalFrontstage React component | |
ModelessDialogInfo | ||
ModelessDialogProps | Properties for the ModelessDialog component | Deprecated |
MouseDownChangedEventArgs | MouseDownChangedEvent Args interface. | Deprecated |
NameToReducerMap | NameToReducerMap used by Reducer Registry | Deprecated |
NavigationAidActivatedEventArgs | NavigationAid Activated Event Args interface. | Deprecated |
NavigationAidHostProps | Properties for the NavigationAidHost React component | Deprecated |
NavigationWidgetComposerProps | Properties for the NavigationWidgetComposer React components | Deprecated |
OpenChildWindowInfo | ||
OverflowToolbarOptions | Properties of enableOverflow component. | |
PanelPinnedChangedEventArgs | Panel pinned changed event args interface. | Deprecated |
PanelStateChangedEventArgs | Panel state changed event args interface. | Deprecated |
PointerMessageChangedEvent arguments. | Deprecated | |
Properties of PointerMessage component. | ||
PopupInfo | Information maintained by PopupManager about a Popup | |
PopupPropsBase | Props for each popup managed by the PopupManager | |
PopupsChangedEventArgs | Deprecated | |
PositionPopupProps | Props for popup at screen position | |
PresentationSelectionScope | PresentationSelectionScope holds the id and the localized label for a selection scope supported for a specific iModel. | Deprecated |
PreviewFeatures | List of preview features that can be enabled/disabled. | |
PreviewFeaturesProviderProps | Props for PreviewFeaturesProvider. | |
QuantityFormatterSettingsOptions | Options to initialize the settings page that allows users to set Quantity formatting overrides. | |
ReactContent | Describes React based content | |
SectionsStatusFieldProps | Sections Status Field Props | |
SelectionCountFieldProps | Properties for the SelectionCountField component. | |
SessionState | The portion of state managed by the SessionStateReducer. | Deprecated |
SessionStateActionsProps | An interface that allows redux connected object to dispatch changes to the SessionState reducer. | Deprecated |
SheetNavigationProps | Properties for the SheetNavigationAid component | |
SplitPaneProps | Props for SplitPane component | Deprecated |
StageContentLayoutProps | StageContentLayoutProps interface for sharing view layout information. | |
StagePanelConfig | Configuration from which a stage panel is created. | |
StagePanelSectionsConfig | Configuration from which stage panel sections are created. | |
StandardFrontstageProps | Props of a StandardFrontstageProvider. | |
StandardLayoutToolbarItem | Describes toolbar item configuration specific to a standard layout. | |
StandardLayoutWidget | Describes widget configuration specific to a standard layout. | |
Properties for StandardMessageBox React component | Deprecated | |
StatusBarActionItem | Describes the data needed to insert an action item into the status bar. | |
StatusBarComposerProps | Properties for the StatusBarComposer React components | Deprecated |
StatusBarCustomItem | Describes the data needed to insert an item into the StatusBar. | |
StatusBarDialogProps | Properties of StatusBarDialog component. | |
StatusBarDialogTitleBarButtonProps | Properties of StatusBarDialogTitleBarButton component. | |
StatusBarDialogTitleBarProps | Properties of StatusBarDialogTitleBar component. | |
StatusBarFieldProps | Properties of StatusBarField component. | Deprecated |
StatusBarIndicatorProps | Properties of StatusBarIndicator component. | Deprecated |
StatusBarLabelIndicatorProps | Properties of StatusBarLabelIndicator component. | Deprecated |
StatusBarLabelItem | Describes the data needed to insert a label item with an optional icon into the status bar. | |
StatusBarProps | Properties for the StatusBar React component | Deprecated |
SupportsViewSelectorChange | Interface to be implemented when the ContentControl supports ViewSelector changes | Deprecated |
SyncToolSettingsPropertiesEventArgs | Sync Tool Settings Properties Event Args interface. | Deprecated |
ToolActivatedEventArgs | Tool Activated Event Args interface. | Deprecated |
ToolAssistanceChangedEventArgs | Tool Assistance Changed event arguments. | Deprecated |
ToolAssistanceFieldProps | Properties of ToolAssistanceField component. | |
ToolbarActionItem | Describes the data needed to insert an action button into a toolbar. | |
ToolbarCustomItem | Describes the data needed to insert a custom button into a toolbar. | |
ToolbarGroupItem | Describes the data needed to insert a group button into a toolbar. | |
ToolbarItemLayouts | Describes toolbar item configuration specific for each layout. | |
ToolbarProps | Properties of Toolbar component. | |
ToolbarWithOverflowProps | Component that displays toolbar items. | |
ToolIconChangedEventArgs | Tool Icon Changed Event Args interface. | Deprecated |
ToolItemProps | Properties for a Tool item with a tool id. | Deprecated |
ToolSettingsEntry | Defines a ToolSettings property entry. | |
ToolSettingsPopupProps | Props for defining a popup tool settings component | |
ToolWidgetComposerProps | Properties for the ToolWidgetComposer React components | Deprecated |
UiDataProvidedDialogProps | Props for UiDataProvidedDialog component. | Deprecated |
UiItemsProvider | Describes interface of objects that want to provide UI component to the running IModelApp. | |
UiItemsProviderRegisteredEventArgs | UiItemsProvider register event args. | Deprecated |
UiSettingsProviderProps | Properties for the UiStateStorageHandler component. | Deprecated |
UiSyncEventArgs | UiSync Event arguments. | Deprecated |
UiVisibilityEventArgs | UiVisibility Event Args interface. | Deprecated |
UnitSystemSelectorProps | Props for UnitSystemSelector | |
UserSettingsProvider | Interface to be implemented but any classes that wants to load their user settings when the UiStateEntry storage class is set. | |
UseSelectionSetSizeArgs | Arguments for useSelectionSetSize hook. | |
ViewLayout | ViewLayout interface for sharing view layout information. | |
ViewOverlayProps | Props of Viewport Overlay Control that show timelines | |
ViewSelectorChangedEventArgs | ViewSelectorChangedEvent Args interface. | Deprecated |
ViewSelectorProps | Properties for the ViewSelector component | |
ViewStateHelperProps | SavedViewProps interface for sharing ViewState and EmphasizeElements information. | |
ViewToolWidgetComposerProps | Props for ViewToolWidgetComposer. | Deprecated |
Widget | Describes the data needed to provide a widget. | |
WidgetConfig | Configuration from which a widget is created. | |
WidgetLayouts | Describes widget configuration specific for each layout. | |
WidgetStateChangedEventArgs | Widget State Changed Event Args interface. | Deprecated |
Namespaces
Name | Description | |
---|---|---|
BackstageItemUtilities | Utilities for creating and maintaining backstage items | |
FrontstageUtilities | Helper namespace to create frontstages. | |
KeyboardShortcutUtilities | Helper class to create keyboard shortcuts. | |
StatusBar | Components used in a StatusBar. | Deprecated |
StatusBarDialog | Components used in a StatusBarDialog. | |
StatusBarItemUtilities | Utility functions for creating and maintaining StatusBar items. | |
StatusBarPopover | Components used in StatusBarPopover . |
|
ToolbarItems | Helper namespace to create commonly used toolbar items. | |
ToolbarItemUtilities | Helper namespace to create toolbar items. |
Type Aliases
Name | Description | |
---|---|---|
ActionsUnion | A TypeScript type alias that represents the Union Type of all actions | |
ActionTypes | A TypeScript type alias that uses conditional types (read: magic) | |
AnyItemDef | Union of all Item definitions that can be specified in a GroupItem | Deprecated |
AnyToolbarItemDef | Union of all Item definitions that can be specified in a Toolbar | |
BackstageItem | Describes the data needed to insert a button into the backstage menu. | |
CardPopupProps | Props for defining a CardPopup editor. | |
CombinedReducerState | A type alias which represents the state created by the reducer returned by combineReducers for a given reducers argument. |
|
CombineReducersFunction | So we don't actually need to implement our own version of combineReducers, but we are going to cast it | Deprecated |
ConditionalBooleanValue | Class used to return a boolean value. | |
ConditionalStringValue | Class used to return a string value. | |
ConfigurableUiActionsUnion | Union of ConfigurableUi Redux actions | Deprecated |
ConfigurableUiControlConstructor | Prototype for ConfigurableUiControl constructor | Deprecated |
ContentCallback | Callback to process content properties during toJSON method | |
CursorPopupProps | Properties for the CursorPopup React component | |
DeepReadonly | Similar to the built-in Readonly, type alias but applied recursively. | |
DeepReadonlyArray | TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work | |
DeepReadonlyObject | TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work | |
Frontstage | Configuration from which a frontstage is created. | |
FunctionType | Shorthand for "any function". | Deprecated |
LocalStateStorage | Implementation of UiStateStorage using Window.localStorage . |
|
MenuItemProps | Menu Item Properties | Deprecated |
Types for NotifyMessageDetails. | ||
Types for message in MessageManager | ||
Placement | Identifies the placement of a given element. | |
PopupContentType | Type for Popup Content | |
ProviderItem | Properties of an item provided by UiItemsProvider. | |
RectangleProps | Describes 2d bounds. | |
Reducer | A Redux Reducer. | |
ReducerActions | A TypeScript type alias that represents a union of all action types handled by a Redux Reducer. | |
ReducerMapActions | A type alias which represents the union type of all actions handled by the reducer returned by combineReducers for a given reducers argument. |
|
SessionStateActionsUnion | Union of SessionState Redux actions | Deprecated |
SettingsManager | Settings Manager class. | |
SettingsTabEntry | Interface used to populate a tab entry in the SettingContainer control | |
SettingsTabsProvider | Setting Provider interface. | |
SizeProps | Describes 2d dimensions. | |
StagePanelMaxSizeSpec | Available units of panel max size. | Deprecated |
StagePanelSectionConfig | Configuration from which a stage panel section is created. | |
StagePanelSizeSpec | Available units of panel size - pixels or percentage of app size. | |
StateType | A TypeScript type alias that represents the return type of a Redux Reducer. | |
StatusBarFieldId | Status Bar Field type. | Deprecated |
StatusBarItem | Describes the data needed to insert a button into the status bar. | |
ThemeId | Describe valid themes. | |
ToolbarItem | Any Button Type that can be inserted into a toolbar. | |
ToolbarPopupProps | Props for a popup toolbar | |
UiItemsProviderOverrides | Allowed overrides applied to a UiItemsProvider the application that registers a provider to limit when it is allowed to provide items. | |
UiStateStorage | Interface for getting, saving and deleting settings. | |
UiStateStorageResult | Interface for result of accessing UI state setting in UiStateStorage. | |
UiStateStorageStatus | Enum for UiStateStorage status. | |
ViewSelectorDefaultProps | Default properties of ViewSelector component. | |
WidgetPanelProps | Widget panel properties used in a StandardFrontstageProps. |
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.