StatusBarLabelIndicatorProps Interface

Deprecated  in 4.14.0. Props of deprecated component StatusBarLabelIndicator.

Properties of StatusBarLabelIndicator component.

Extends

Properties

Name Type Description
iconSpec IconSpec | undefined Specification of an icon.  
label string | undefined Indicator label.  
labelSide StatusBarLabelSide | undefined Side to display label.  

Inherited properties

Name Type Inherited from Description
className Inherited string | undefined Omit Custom CSS class name
defaultIsOpen Inherited boolean | undefined Omit Default state of an indicator popup.
itemId Inherited string | undefined Omit Optional unique identifier for item.
onClick Inherited () => void | undefined Omit Function called when indicator is clicked.
popup Inherited React.ReactNode | undefined Omit Content to display in a popup when indicator is clicked.
style Inherited React.CSSProperties | undefined Omit Custom CSS style properties
title Inherited string | undefined Omit Title of an indicator.

Defined in

Last Updated: 30 January, 2025