ViewDefinitions
Classes for working with Elements that define what appears in Views. See the learning articles.
Classes
Name | Description | |
---|---|---|
AuxCoordSystem | An auxiliary coordinate system element. | |
AuxCoordSystem2d | A 2d auxiliary coordinate system. | |
AuxCoordSystem3d | A 3d auxiliary coordinate system. | |
AuxCoordSystemSpatial | A spatial auxiliary coordinate system. | |
CategorySelector | Holds a list of Ids of Categories to be displayed in a view. | |
DisplayStyle | A DisplayStyle defines the parameters for 'styling' the contents of a view. | |
DisplayStyle2d | A DisplayStyle for 2d views. | |
DisplayStyle3d | A DisplayStyle for 3d views. | |
DrawingViewDefinition | Defines a view of a DrawingModel. | |
ModelSelector | Holds the list of Ids of GeometricModels displayed by a SpatialViewDefinition. | |
OrthographicViewDefinition | Defines a spatial view that displays geometry on the image plane using a parallel orthographic projection. | |
SheetViewDefinition | Defines a view of a SheetModel. | |
SpatialViewDefinition | Defines a view of one or more SpatialModels. | |
ViewAttachment | Represents an attachment of a ViewDefinition to a Sheet. | |
ViewDefinition | The definition element for a view. | |
ViewDefinition2d | Defines a view of a single 2d model. | |
ViewDefinition3d | Defines a view of one or more 3d models. |
Interfaces
Name | Description | |
---|---|---|
DisplayStyleCreationOptions | Describes initial settings for a new DisplayStyle3d. |
Namespaces
Name | Description | |
---|---|---|
ViewStore | A ViewStore is a database that stores Views and related data. |
Last Updated: 16 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.