iModels
Types for working with iModels in both the frontend and backend.
Classes
Name | Description | |
---|---|---|
BackendError | ||
BentleyError | Base exception class for iTwin.js exceptions. | |
BlobOptionsBuilder | ||
BlobReader | ||
ConflictingLocksError | An error raised when there is a lock conflict detected. | Deprecated |
DbQueryError | ||
EcefLocation | The position and orientation of an iModel on the earth in ECEF (Earth Centered Earth Fixed) coordinates | |
ECSqlReader | Execute ECSQL statements and read the results. | |
IModel | Represents an iModel in JavaScript. | |
IModelError | The error type thrown by this module. | |
IModelVersion | Option to specify the version of the iModel to be acquired and used | |
NoContentError | Intended for API "no content" semantics where the error case should not trigger application failure monitoring systems. | |
PropertyMetaDataMap | ||
QueryBinder | Bind values to an ECSQL query. | |
QueryOptionsBuilder | ||
ServerError | ||
ServerTimeoutError | ||
Uint8Chunks |
Enumerations
Name | Description | |
---|---|---|
BentleyStatus | Standard status code. | |
BriefcaseIdValue | Values of BriefcaseId that have special meaning. | |
BriefcaseStatus | Error statuses produced by various briefcase operations, typically encountered as the errorNumber of an IModelError. |
|
ChangeSetStatus | Error statuses produced by various Changeset operations, typically encountered as the errorNumber of an IModelError. |
|
ChangesetType | Value to indicate whether a changeset contains schema changes or not | |
DbResult | Values for return codes from BeSQLite functions. | |
DomainOptions | Option to control the validation and upgrade of domain schemas in the Db | |
GeoCoordStatus | This enumeration lists all possible status as returned from a coordinate conversion to or from a | |
IModelStatus | Status codes that are used in conjunction with BentleyError. | |
LockState | The state of a lock. | |
ProfileOptions | Options that control whether a profile upgrade should be performed when opening a Db | |
QueryRowFormat | Specifies the format of the rows returned by the query and restartQuery methods of |
|
SchemaState | The state of the schemas in the Db compared with what the current version of the software expects | |
SyncMode | Whether a briefcase is editable or may only accept incoming changesets from iModelHub | |
TxnAction | Describes the types of actions associated with Txns. |
Global Functions
Name | Description | |
---|---|---|
mapToGeoServiceStatus | Maps a GeoCoordStatus to the equivalent GeoServiceStatus. |
Interfaces
Name | Description | |
---|---|---|
BaseReaderOptions | Config for all request made to concurrent query engine. | |
BlobOptions | ||
BriefcaseDownloader | Manages the download of a briefcase | |
BriefcaseProps | Properties that specify a briefcase within the local briefcase cache. | |
ChangesetIdWithIndex | The Id and optionally the index of a changeset | |
ChangesetIndexAndId | Both the index and Id of a changeset | |
ChangesetProps | Properties of a changeset | |
ChangesetRange | A range of changesets | |
CloudContainerUri | TODO documentation | |
ConflictingLock | Detailed information about a particular object Lock that is causing the Lock update conflict. | Deprecated |
CreateIModelProps | The properties that can be supplied when creating a new iModel. | |
CreateSnapshotIModelProps | Options that can be supplied when creating snapshot iModels. | |
DbRuntimeStats | ||
EcefLocationProps | Properties that position an iModel on the earth via ECEF (Earth Centered Earth Fixed) coordinates | |
FilePropertyProps | ||
GeoCoordinatesRequestProps | Information required to request conversion of an array of iModel coordinates to Geographic Coordinates (longitude and latitude) | |
GeoCoordinatesResponseProps | Information returned from a request to convert an array of iModel coordinates to Geographic Coordinates (longitude and latitude) | |
GeographicCRSInterpretRequestProps | Information required to interpret or complete a Geographic CRS in the specified format. | |
GeographicCRSInterpretResponseProps | Information returned from a request to interpret or complete a Geographic CRS | |
IModelCoordinatesRequestProps | Information required to request conversion of an array of Geographic coordinates (Longitude/Latitude) to iModel coordinates | |
IModelCoordinatesResponseProps | ||
IModelEncryptionProps | Encryption-related properties that can be supplied when creating or opening snapshot iModels. | Deprecated |
IModelProps | Properties of an iModel that are always held in memory whenever one is opened, both on the frontend and on the backend . | |
IModelRpcOpenProps | The properties to open a connection to an iModel for RPC operations. | |
IModelRpcProps | The properties that identify an opened iModel for RPC operations. | |
InUseLock | Detailed information about a particular object Lock that is causing the Lock update conflict. | |
InUseLocksError | An error raised when there is a lock conflict detected. | |
ITwinError | An interface used to describe an error for a developer/application. | |
LocalBriefcaseProps | Properties of a local briefcase file, returned by BriefcaseManager.getCachedBriefcases and BriefcaseManager.downloadBriefcase | |
OpenBriefcaseOptions | Options to open a previously downloaded briefcase | |
OpenBriefcaseProps | Properties for opening a local briefcase file via BriefcaseDb.open | |
OpenCheckpointArgs | Arguments to open a Checkpoint directly from its cloud container | |
OpenDbKey | A key used to identify an opened IModelDb between the frontend and backend for Rpc and Ipc communications. | |
OpenSqliteArgs | Sqlite options. | |
PointWithStatus | A point converted to iModel coordinates to geographic coordinates or vice-versa by a GeoConverter. | |
QueryLimit | Specify limit or range of rows to return | |
QueryOptions | ECSql query config | |
QueryPropertyMetaData | ||
QueryQuota | Quota hint for the query. | |
QueryRowProxy | Methods and ways of accessing values from rows returned by ECSqlReader. | |
QueryStats | Performance-related statistics for ECSqlReader. | |
RequestNewBriefcaseProps | Properties for downloading a briefcase to a local file, from iModelHub. | |
RootSubjectProps | Properties of the Root Subject. | |
SnapshotOpenOptions | Options to open a SnapshotDb. | |
UpgradeOptions | Arguments to validate and update the profile and domain schemas when opening a Db |
Namespaces
Name | Description | |
---|---|---|
InUseLocksError | ||
ITwinError |
Type Aliases
Name | Description | |
---|---|---|
BlobRange | ||
BriefcaseId | The Id assigned to a briefcase by iModelHub, or Unassigned . | |
ChangesetId | A string that identifies a changeset. | |
ChangesetIndex | The index of a changeset, assigned by iModelHub. | |
ChangesetIndexOrId | either changeset index, id, or both | |
CreateEmptySnapshotIModelProps | The options that can be specified when creating an empty snapshot iModel. | |
GetMetaDataFunction | A function that returns a metadata object for a BentleyError. | |
IModelConnectionProps | The properties returned by the backend when creating a new IModelConnection from the frontend, either with Rpc or with Ipc. | |
IModelErrorNumber | Numeric values for common errors produced by iTwin.js APIs, typically provided by IModelError. | |
IModelVersionProps | Properties for IModelVersion | |
LocalDirName | ||
LocalFileName | ||
LogFunction | Defines the signature for a log function. | |
LoggingMetaData | Optional metadata attached to a BentleyError. | |
QueryValueType | The format for rows returned by ECSqlReader. | |
StandaloneOpenOptions | Options to open a StandaloneDb via StandaloneDb.openFile from the backend, |
Last Updated: 19 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.