iModels
Classes for working with iModels. See the learning article.
Classes
Name | Description | |
---|---|---|
BriefcaseDb | A local copy of an iModel from iModelHub that can pull and potentially push changesets. | |
BriefcaseManager | Manages downloading Briefcases and downloading and uploading changesets. | |
Category | A Category element is the target of the category member of GeometricElement. |
|
ChangeSummaryManager | Class to extract Change Summaries for a briefcase. | |
DrawingCategory | Categorizes 2d GeometricElements. | |
IModelDb | An iModel database file. | |
IModelElementCloneContext | The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel. | |
SnapshotDb | A snapshot iModel database file that is used for archival and data transfer purposes. | |
SpatialCategory | Categorizes SpatialElements. | |
StandaloneDb | Standalone iModels are read/write files that are not associated with an iTwin or managed by iModelHub. | |
SubCategory | Defines the appearance for graphics in Geometric elements | |
TxnManager | Manages local changes to a BriefcaseDb or StandaloneDb via Txns |
Constants
Name | Description | |
---|---|---|
IModelCloneContext | Deprecated |
Enumerations
Name | Description | |
---|---|---|
ProgressStatus | Return value from ProgressFunction. |
Global Functions
Name | Description | |
---|---|---|
getAvailableCoordinateReferenceSystems | Get a list of Geographic Coordinate Reference Systems. |
Interfaces
Name | Description | |
---|---|---|
AvailableCoordinateReferenceSystemProps | Describes a geographic coordinate reference system produced by getAvailableCoordinateReferenceSystems. | |
ChangeInstanceKey | Represents a change (insertion, deletion, or modification) to a single EC instance made in a local BriefcaseDb. | |
ChangeSummary | Represents an instance of the ChangeSummary ECClass from the ECDbChange ECSchema |
|
CheckpointProps | Properties of a checkpoint | |
CloudContainerArgs | Augments a SnapshotDbOpenArgs or OpenBriefcaseArgs with a CloudContainer. | |
ComputedProjectExtents | The result of computeProjectExtents. | |
ComputeProjectExtentsOptions | Options supplied to computeProjectExtents. | |
CreateChangeSummaryArgs | Options for ChangeSummaryManager.createChangeSummaries. | |
GetAvailableCoordinateReferenceSystemsArgs | Arguments supplied to getAvailableCoordinateReferenceSystems. | |
InstanceChange | Represents an instance of the InstanceChange ECClass from the ECDbChange ECSchema |
|
LockControl | Interface for acquiring element locks to coordinate simultaneous edits from multiple briefcases. | |
PushChangesArgs | Parameters for pushing changesets to iModelHub | |
QueryLocalChangesArgs | Arguments supplied to queryLocalChanges. | |
RequestNewBriefcaseArg | The argument for downloadBriefcase | |
SchemaImportOptions | Options for the importing of schemas | |
ToChangesetArgs | Specifies a specific index for pulling changes. | |
TokenArg | Argument to a function that can accept a valid access token. | |
TxnChangedEntities | Describes a set of Elements or Models that changed as part of a transaction. | |
UpdateModelOptions | Options for IModelDb.Models.updateModel | |
ValidationError | An error generated during dependency validation. |
Namespaces
Name | Description | |
---|---|---|
IModelDb |
Type Aliases
Name | Description | |
---|---|---|
IModelCloneContext | Deprecated | |
OpenBriefcaseArgs | Arguments to open a BriefcaseDb | |
ProgressFunction | Called to show progress during a download. | |
PullChangesArgs | Arguments for pullAndApplyChangesets | |
RevertChangesArgs | Arguments for revertTimelineChanges | |
SnapshotDbOpenArgs | Options to open a SnapshotDb. | |
TxnIdString | A string that identifies a Txn. |
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.