Backstage
Classes for working with a Backstage
Classes
Name | Description | |
---|---|---|
BackstageManager | Controls backstage. | Deprecated |
Global Functions
Name | Description | |
---|---|---|
BackstageComposer | Backstage component composed from backstage items. | |
isBackstageActionItem | BackstageActionItem type guard. | |
isBackstageStageLauncher | BackstageStageLauncher type guard. | |
useBackstageManager | Hook that returns backstage manager. | |
useIsBackstageOpen | Hook that returns isOpen flag of the backstage. |
Interfaces
Name | Description | |
---|---|---|
BackstageActionItem | Describes the data needed to insert an action button into the backstage menu. | |
BackstageComposerProps | Props of BackstageComposer component. | Deprecated |
BackstageStageLauncher | Describes the data needed to insert an action button into the backstage menu. | |
BackstageToggledArgs | Arguments of onToggled. | |
CommonBackstageItem | Describes the data needed to insert a button into the backstage menu. | |
FrameworkBackstage | backstage interface. |
Namespaces
Name | Description | |
---|---|---|
BackstageItemUtilities | Utilities for creating and maintaining backstage items |
Type Aliases
Name | Description | |
---|---|---|
BackstageItem | Describes the data needed to insert a button into the backstage menu. |
Last Updated: 19 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.