Core
Common types used all across presentation-components package.
Classes
Name | Description | |
---|---|---|
ContentDataProvider | Base class for all presentation-driven content providers. |
Global Functions
Name | Description | |
---|---|---|
createDiagnosticsOptions | Creates diagnostics options that can be passed to presentation requests based on given | |
deserializeUniqueValues | Function for deserializing displayValues and groupedRawValues . |
|
memoize | ||
PortalTargetContextProvider | Provides a portal target for components. | Deprecated |
SchemaMetadataContextProvider | Provides schema metadata to components that work with schemas. | |
serializeUniqueValues | Function for serializing UniqueValue . |
|
useRulesetRegistration | Custom hook which registers supplied Ruleset on mount and removes on unmount. | Deprecated |
useSchemaMetadataContext | Returns context provided by SchemaMetadataContextProvider. |
Interfaces
Name | Description | |
---|---|---|
CacheInvalidationProps | Properties for invalidating content cache. | |
ContentDataProviderProps | Properties for creating a ContentDataProvider instance. |
|
DiagnosticsProps | Settings for capturing diagnostics data. | |
IContentDataProvider | Interface for all presentation-driven content providers. | |
IPresentationDataProvider | Interface for a presentation data provider | |
IUnifiedSelectionComponent | An interface for all unified selection components | |
PortalTargetContextProviderProps | Props for PortalTargetContextProvider | Deprecated |
SchemaMetadataContext | Context that stores metadata related to schemas. | |
SchemaMetadataContextProviderProps | Props for SchemaMetadataContextProvider | |
UniqueValue |
Namespaces
Name | Description | |
---|---|---|
CacheInvalidationProps |
Last Updated: 30 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.