Toolbar
Classes used to construct a Toolbar
Classes
Name | Description | |
---|---|---|
ToolbarHelper | Helper functions for defining a Toolbar items used in Toolbar , ToolbarComposer and UiItemsProvider . |
Deprecated |
Enumerations
Name | Description | |
---|---|---|
ToolbarOrientation | Used to specify the orientation of the toolbar. | |
ToolbarUsage | Used to specify the usage of the toolbar which determine the toolbar position. |
Global Functions
Name | Description | |
---|---|---|
isToolbarActionItem | ToolbarActionItem type guard. | |
isToolbarCustomItem | ToolbarCustomItem type guard. | |
isToolbarGroupItem | ToolbarGroupItem type guard. | |
Toolbar | Component that displays toolbar items. | |
ToolbarComposer | Toolbar that is populated and maintained by UI item providers. | |
ToolbarWithOverflow | Component that displays toolbar items, displaying only the elements that can fit in the available space, | |
useDefaultToolbarItems | Hook that returns items from ToolbarItemsManager. | Deprecated |
useUiItemsProviderToolbarItems | Hook that retrieves active frontstage toolbar items from UiItemsProviders and manage them through ToolbarItemsManager. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
CommonToolbarItem | Describes the data needed to insert a UI items into an existing set of UI items. | |
ExtensibleToolbarProps | Properties for the ToolbarComposer React components | Deprecated |
OverflowToolbarOptions | Properties of enableOverflow component. | |
StandardLayoutToolbarItem | Describes toolbar item configuration specific to a standard layout. | |
ToolbarActionItem | Describes the data needed to insert an action button into a toolbar. | |
ToolbarCustomItem | Describes the data needed to insert a custom button into a toolbar. | |
ToolbarGroupItem | Describes the data needed to insert a group button into a toolbar. | |
ToolbarItemLayouts | Describes toolbar item configuration specific for each layout. | |
ToolbarProps | Properties of Toolbar component. | |
ToolbarWithOverflowProps | Component that displays toolbar items. |
Namespaces
Name | Description | |
---|---|---|
ToolbarItemUtilities | Helper namespace to create toolbar items. |
Type Aliases
Name | Description | |
---|---|---|
ToolbarItem | Any Button Type that can be inserted into a toolbar. |
Last Updated: 19 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.