appui-abstract

Classes

Name Description
BaseQuantityDescription Base Quantity Property Description
ConditionalBooleanValue Class used to return a boolean value.
ConditionalStringValue Class used to return a string value.
DialogLayoutDataProvider DialogLayoutDataProvider Abstract class that allows property values to be passed between hosting API and Dialog that generates and arranges components dynamically
DialogProperty DialogProperty is a generic helper class that assists working with properties used by UiLayoutDataProvider implementations (i.e.
GenericUiEvent The GenericUiEvent is the base event class for UI events that target a specific component, as identified in uiComponentId.
IconSpecUtilities Creates an IconSpec with an SVG source and gets the SVG source from an IconSpec. Deprecated
PropertyDescriptionHelper Helper class that builds property descriptions for specific PropertyEditors and processes descriptions.
PropertyRecord PropertyRecord contains instance information about a Property, including a
StandardContentLayouts Class that define Standard Content Layouts that can be used to specify how the content is arranged in a frontstage. Deprecated
SyncPropertiesChangeEvent Sync UI Control Properties Event class.
ToolbarItemUtilities Helper class to create Abstract StatusBar Item definitions.
UiAdmin The UiAdmin controls various UI components and is callable from IModelApp.uiAdmin in the core-frontend package.
UiDataProvider UiDataProvider Abstract class that allows property values to be passed between hosting API and UI.
UiError iTwin.js UI UiError class is a subclass of BentleyError. Deprecated
UiEvent iTwin.js UI UiEvent class is a subclass of BeEvent with argument type safety.
UiEventDispatcher This class is used to send eventIds to interested UI components so the component can determine if it needs Deprecated
UiLayoutDataProvider
UiSyncEvent UiSync Event class. Deprecated

Enumerations

Name Description
AlternateDateFormats Alternate Data Formats that can be provide by javascript.
BadgeType Specifies type of badge, if any, that should be overlaid on UI component.
DialogButtonStyle Enum for button style.
DialogButtonType Enum for button types.
DisplayMessageType Describes the type and behavior of a display message.
FunctionKey Enumeration for Function Keys Deprecated
MessageSeverity Message Severity enum for display messages.
PropertyChangeStatus Status of Proposed property changes from UI to UiDataProvider
PropertyEditorParamTypes Enum for Property Editor Param Types
PropertyValueFormat Enumeration for Format of the property value.
RelativePosition Relative Position for popups
SpecialKey Enumeration for Special Keys Deprecated
StandardEditorNames Standard Editor Names for property editors.
StandardTypeNames Standard Type Names for converters and editors.
TimeDisplay Enum that defines supported time formats.

Global Functions

Name Description
isArrowKey Determines if a KeyboardEvent.key is an Arrow key Deprecated
isButtonGroupEditorParams
isColorEditorParams
isCustomFormattedNumberParams
isIconListEditorParams
isInputEditorSizeParams
isSuppressLabelEditorParams

Interfaces

Name Description
AbstractActionItemProps Definition for an item that executes and action.
AbstractMenuItemProps Properties for a Menu item
AbstractToolbarProps Definition for a Toolbar.
ActionButton Describes the data needed to insert an action button into a toolbar.
ArrayValue Array property value
BaseDialogItem BaseDialogItem contains only the members necessary to create a PropertyRecord.
BasePropertyEditorParams BasePropertyEditorParams Base interface for Property Editor Params
BasePropertyValue Base interface for a property value
ButtonGroupEditorParams ButtonGroupEditorParams Parameters used by EnumButtonGroupEditor to define icons in button group.
ColorEditorParams ColorEditorParams Parameters used to populate color type editor with a specific set of colors.
CommandHandler Definition for a command handler.
CommonItemProps Definition that specifies properties shared between many ConfigurableUi components.
ContentLayoutProps Properties for a ContentLayoutDef Deprecated
CustomButtonDefinition Describes the data needed to insert a custom button into a toolbar.
CustomFormattedNumberParams Parameters used with properties that want to control parsing and formatting.
DateFormatter Interface used to provide a custom Date Time formatter and optional parser
DialogButtonDef Interface for a dialog button in a button cluster
DialogItem DialogItem is the specification that the display engine turns into a UI item.
DialogItemValue DialogItemValue Interface of PrimitiveValue types that have type editor support for use in dialogs.
DialogPropertyItem DialogPropertyItem is the specification to use if you are defining the components directly, e.g., in React
DialogPropertySyncItem DialogPropertySyncItem is used to pass sync messages for DialogPropertyItems
DialogProps Optional props to pass to the Dialog control that is generated.
DialogRow DialogRow is the interface that groups dialog items into rows for building UI
EditorPosition EditorPosition Interface used to identify the location of the item a DialogItem property value.
EnumerationChoice Information about an enumeration choice
EnumerationChoicesInfo Information about a set of enumeration choices
GenericUiEventArgs The Generic UI Event args contains information useful for any UI message
GroupButton Describes the data needed to insert a group button into a toolbar.
IconDefinition IconDefinition Information about an icon displayed next to a property editor.
IconEditorParams Parameters used to display an icon next to property editor.
IconListEditorParams IconListEditorParams Parameters used to populate icon type editor with a specific set of icons.
ImageCheckBoxParams Parameters for ImageCheckBoxEditor
IMatch Interface that returns indices of matches Deprecated
InputEditorSizeParams InputEditorSizeParams type guard.
LayoutFragmentProps Properties for a layout fragment Deprecated
LayoutHorizontalSplitProps Properties for a horizontal layout split Deprecated
LayoutSplitPropsBase Base interface for layout split properties Deprecated
LayoutVerticalSplitProps Properties for a vertical layout split. Deprecated
LinkElementsInfo Properties for the PropertyRecord with link info supplied
MessagePresenter MessagePresenter interface functions display messages.
MultilineTextEditorParams Parameter that is used to indicate that a multiline text editor should be created.
ParseResults defines Results of parsing a string input by a user into its desired value type
PointProps Describes 2d points. Deprecated
PrimitiveValue Primitive property value
PropertyChangeResult Interface used by UiDataProvider to report change status (validation) to UI.
PropertyConverterInfo Information about a Property Converter
PropertyDescription PropertyDescription contains metadata about a Property
PropertyEditorInfo Information about a Property Editor
PropertyRendererInfo Property renderer identification and customization attributes
RangeEditorParams Parameters used by PropertyEditors that support defining a minimum and maximum value.
SliderEditorParams Parameters used to indicate that a Slider should be presented for the property
StructValue Struct property value
SuppressLabelEditorParams SuppressLabelEditorParams Parameters used to suppress the label for a type editor in the ToolSettings widget.
SyncPropertiesChangeEventArgs Sync UI Control Properties Event Args interface.
ToolbarItem Describes the data needed to insert a UI items into an existing set of UI items.
UiFlags Flags that control enabling/disabling certain UI features
UiSyncEventArgs UiSync Event arguments. Deprecated

Namespaces

Name Description
Primitives Primitive Property Value Types.

Type Aliases

Name Description
CommonToolbarItem Any Button Type that can be inserted into a toolbar.
OnCancelFunc Signature for onCancel function.
OnItemExecutedFunc Signature for onItemExecuted function.
OnNumberCommitFunc Signature for number onCommit function.
OnValueCommitFunc Signature for value onCommit function.
PropertyEditorParams Type definition for Property Editor params
PropertyValue Type for all property values
StringGetter Prototype for string getter function.

Last Updated: 03 February, 2025