ContentLayoutDef Class
Content Layout Definition class.
Methods
Name | Description | |
---|---|---|
constructor(layoutProps: ContentLayoutProps): ContentLayoutDef | ||
fillLayoutContainer(contentNodes: React.ReactNode[], resizable: boolean): React.ReactNode | Fill a layout container with React nodes for each content view. | Deprecated |
getUsedContentIndexes(): number[] | Gets the indexes of content views used in this Content Layout. | |
toJSON(): ContentLayoutProps | Creates ContentLayoutProps for JSON purposes |
Properties
Name | Type | Description | |
---|---|---|---|
description | string | Description of the layout. | |
id | string | ID for this Content Layout | |
rootSplit Accessor ReadOnly | undefined | LayoutSplit |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.