Hierarchies
Types related to presentation hierarchies.
Enumerations
Name | Description | |
---|---|---|
StandardNodeTypes | Standard node types |
Interfaces
Name | Description | |
---|---|---|
BaseNodeKey | Data structure that describes a basic node key | |
ECClassGroupingNodeKey | Data structure that describes an ECClass grouping node key | |
ECInstancesNodeKey | Data structure that describes a node ECInstance node key | |
ECPropertyGroupingNodeKey | Data structure that describes an ECProperty grouping node key | |
ECValueBinding | Defines an EC value binding. | |
ECValueSetBinding | Defines a binding for a list of EC values for use with InVirtualSet ECSQL function. |
|
GroupingNodeKey | Data structure that describes a grouping node key | |
HierarchyLevel | Defines a hierarchy level that consists of an array of nodes and possibly other information. | |
IdBinding | Defines an Id64String value binding. | |
IdSetBinding | Defines an IdSet value binding for use with InVirtualSet ECSQL function. |
|
LabelCompositeValue | Data structure that describes raw composite label value. | |
LabelDefinition | Data structure that describes label definition. | |
LabelGroupingNodeKey | Data structure that describes a display label grouping node key | |
Node | Data structure that describes a tree node. | |
NodePathElement | Describes a single step in the nodes path. | |
NodePathFilteringData | Data related to node hierarchy filtering | |
PresentationQuery | Data structure that describes a presentation query |
Namespaces
Name | Description | |
---|---|---|
LabelDefinition | ||
NodeKey |
Type Aliases
Name | Description | |
---|---|---|
LabelRawValue | Type definition of label raw value. | |
NodeKey | One of the node key types | |
NodeKeyPath | Node key path. | |
PartialNode | Partial node definition. | |
PresentationQueryBinding | One of the PresentationQuery binding types. |
Last Updated: 06 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.