Errors

Classes for working with errors.

Classes

Name Description  
BentleyError Base exception class for legacy iTwin.js errors.  
UnexpectedErrors Utility for handling/reporting unexpected runtime errors.  

Enumerations

Name Description  
BentleyStatus Standard status code.  
BriefcaseStatus Error statuses produced by various briefcase operations, typically encountered as the errorNumber of an IModelError.  
ChangeSetStatus Error statuses produced by various Changeset operations, typically encountered as the errorNumber of an IModelError.  
GeoServiceStatus GeoServiceStatus errors  
HttpStatus Status from returned HTTP status code  
IModelHubStatus Statuses produced by APIs that interact with iModelHub, typically encountered as the errorNumber of an IModelError.  
IModelStatus Status codes that are used in conjunction with BentleyError.  
RpcInterfaceStatus RpcInterface status codes  

Interfaces

Name Description  
ITwinError The interface that all exceptions thrown by iTwin.js libraries and applications should implement.  
ITwinErrorId Uniquely identifies a specific kind of ITwinError.  
LegacyITwinErrorWithNumber An ITwinError that also supplies an errorNumber.  

Namespaces

Name Description  
ITwinError  

Type Aliases

Name Description  
GetMetaDataFunction A function that returns a metadata object for a BentleyError.  
Optional metadata attached to a BentleyError.  
OnUnexpectedError A function to be notified when an unexpected error happens  

Last Updated: 16 April, 2025