BentleyError Class

Base exception class for legacy iTwin.js errors. For backwards compatibility only. Do not create new subclasses of BentleyError. Instead use ITwinError.

Extends

  • Error

Methods

Name Description
constructor(errorNumber: number, message?: string, metaData?: LoggingMetaData): BentleyError    
_initName(): string Protected This function returns the name of each error status.  
get the meta data associated with this BentleyError, if any.  
getErrorKey(errorNumber: number): string Static This function returns the name of each error status.  
getErrorMessage(error: unknown): string Static Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.  
Use run-time type checking to safely get the metadata with an unknown error value, if possible.  
getErrorProps(error: unknown): ErrorProps Static Returns a new ErrorProps object representing an unknown error value.  
getErrorStack(error: unknown): undefined | string Static Use run-time type checking to safely get the call stack of an unknown error value, if possible.  
get the metadata object associated with an ExceptionMetaData, if any.  
isError<T extends LegacyITwinErrorWithNumber>(error: unknown, errorNumber?: number): error is T Static Determine if an error object implements the LegacyITwinErrorWithNumber interface.  

Properties

Name Type Description
errorNumber number The a number that identifies of the problem.  
boolean Returns true if this BentleyError includes (optional) metadata.  
iTwinErrorId Accessor ReadOnly { key: string, scope: string } supply the value for iTwinErrorId  
iTwinErrorScope Static Readonly "bentley-error"    
undefined | object value for logging metadata  

Defined in

Last Updated: 03 April, 2025