LegacyITwinErrorWithNumber Interface
An ITwinError that also supplies an errorNumber
.
@note this interface exists only for legacy errors derived from BentleyError
. The concept of "error number" is
problematic since it is impossible to enforce across the iTwin.js library, let alone across applications. New code should
use ITwinError
and identify errors with strings instead.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
errorNumber Readonly | number | a number to identify the error. | |
loggingMetadata | object | undefined | Logging metadata |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
iTwinErrorId Readonly Inherited | ITwinErrorId | ITwinError | Uniquely identifies the kind of error. |
Defined in
- core/bentley/src/BentleyError.ts Line 392
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.