Polyface
A Polyface is a mesh structure with arrays of points that are shared among multiple incident facets.
Classes
Name |
Description |
|
AuxChannel |
Represents a single PolyfaceAuxData channel. |
|
AuxChannelData |
Represents the AuxChannel data at a single input value. |
|
ClippedPolyfaceBuilders |
A pair of PolyfaceBuilder objects, for use by clippers that emit inside and outside parts. |
|
ConvexFacetLocationDetail |
Implementation of FacetLocationDetail for a convex facet. |
|
FacetFaceData |
Data for a face in a polyface containing facets. |
|
FacetIntersectOptions |
Options for computing and processing facet intersection methods. |
|
FacetLocationDetailPair |
A pair of FacetLocationDetail. |
|
FacetOffsetProperties |
|
|
FacetOrientationFixup |
|
|
IndexedEdgeMatcher |
An IndexedEdgeMatcher carries an array (edges ) of edges start & end indices for sorting and subsequent analyses (such as testing for closed mesh) |
|
IndexedPolyface |
An IndexedPolyface is a set of facets which can have normal, param, and color arrays with independent point, |
|
IndexedPolyfaceSubsetVisitor |
An IndexedPolyfaceSubsetVisitor is an IndexedPolyfaceVisitor which only visits a subset of facets in the polyface. |
|
IndexedPolyfaceVisitor |
An IndexedPolyfaceVisitor is an iterator-like object that "visits" facets of a mesh. |
|
NonConvexFacetLocationDetail |
Implementation of FacetLocationDetail for a general facet, which may or may not be convex. |
|
OffsetMeshContext |
|
|
OffsetMeshOptions |
Options carrier for cloneOffset. |
|
Polyface |
A Polyface is an abstract mesh structure (of unspecified implementation) that provides a PolyfaceVisitor |
|
PolyfaceAuxData |
The PolyfaceAuxData structure contains one or more analytical data channels for each vertex of a Polyface, allowing the polyface to be styled |
|
PolyfaceBuilder |
* Simple construction for strongly typed GeometryQuery objects: |
|
PolyfaceClip |
PolyfaceClip is a static class gathering operations using Polyfaces and clippers. |
|
PolyfaceData |
PolyfaceData carries data arrays for point, normal, uv-parameters, and color, and index arrays for each. |
|
PolyfaceQuery |
PolyfaceQuery is a static class whose methods implement queries on a Polyface or PolyfaceVisitor provided as a |
|
SectorOffsetProperties |
Sector properties during offset. |
|
SortableEdge |
* For boundary sorting, an edge is a (packed!) Float64Array. |
|
SweepLineStringToFacetContext |
|
|
SweepLineStringToFacetsOptions |
Options carrier for sweeping linework onto meshes. |
|
TaggedNumericData |
Structure with 2 integer tags and optional arrays of integers, doubles, points, vectors, and geometry. |
|
TriangularFacetLocationDetail |
Implementation of FacetLocationDetail for a triangular facet. |
|
Enumerations
Interfaces
Namespaces
Type Aliases
Last Updated: 24 October, 2024