Name |
Description |
|
BatchOptions |
Options used when constructing a Batch - that is, a RenderGraphic with an associated FeatureTable describing individual Features within the |
|
CanvasDecoration |
A Decoration that is drawn onto the |
|
ComputeChordToleranceArgs |
Arguments used to compute the chord tolerance (level of detail) of the RenderGraphic or GraphicTemplate produced by a GraphicBuilder. |
|
ComputeGraphicDescriptionChordToleranceArgs |
Arguments supplied to computeChordTolerance to help compute an appropriate level of detail for the GraphicDescription. |
|
CreateGraphicFromDescriptionArgs |
Arguments supplied to createGraphicFromDescription. |
|
CreateGraphicFromTemplateArgs |
Arguments supplied to createGraphicFromTemplate. |
|
CreateRenderInstancesParamsBuilderArgs |
Arguments supplied to RenderInstancesParamsBuilder.create. |
|
CreateRenderMaterialArgs |
Arguments supplied to createRenderMaterial. |
|
CreateTextureArgs |
Arguments supplied to createTexture to create a RenderTexture. |
|
CreateTextureFromSourceArgs |
Arguments supplied to createTextureFromSource. |
|
CustomGraphicBuilderOptions |
Options for creating a GraphicBuilder to produce a RenderGraphic or GraphicTemplate that is not associated with any particular Viewport and may not be associated with |
|
DecorateContextCreateArgs |
Arguments supplied to DecorateContext.create. |
|
GraphicArc |
A GraphicPrimitive representing a 3d open arc or closed ellipse that can be supplied to addPrimitive. |
|
GraphicArc2d |
A GraphicPrimitive representing a 2d open arc or closed ellipse that can be supplied to addPrimitive. |
|
GraphicBranchOptions |
Options passed to createGraphicBranch. |
|
GraphicBuilderOptions |
Options for creating a GraphicBuilder used by functions like createGraphic and createGraphic. |
|
GraphicDescription |
An opaque representation of a RenderGraphic created by a GraphicDescriptionBuilder. |
|
GraphicDescriptionBuilder |
An equivalent of a GraphicBuilder that is designed for use on a Worker. |
|
GraphicDescriptionContext |
Context holding resources like transient Ids, textures, and materials that were allocated on a Worker by a |
|
GraphicDescriptionContextProps |
Describes a GraphicDescriptionContext returned from a Worker to the main thread, holding resources like |
|
GraphicLineString |
A GraphicPrimitive representing a line string that can be supplied to addPrimitive. |
|
GraphicLineString2d |
A GraphicPrimitive representing a 2d line string that can be supplied to addPrimitive. |
|
GraphicLoop |
A GraphicPrimitive representing a 3d planar region that can be supplied to addPrimitive. |
|
GraphicPath |
A GraphicPrimitive representing a 3d open path that can be supplied to addPrimitive. |
|
GraphicPointString |
A GraphicPrimitive representing a point string that can be supplied to addPrimitive. |
|
GraphicPointString2d |
A GraphicPrimitive representing a 2d point string that can be supplied to addPrimitive. |
|
GraphicPolyface |
A GraphicPrimitive representing a mesh that can be supplied to addPrimitive. |
|
GraphicPrimitive2d |
Base interface for a 2d GraphicPrimitive that can be supplied to addPrimitive. |
|
GraphicShape |
A GraphicPrimitive representing a closed 3d planar region that can be supplied to addPrimitive. |
|
GraphicShape2d |
A GraphicPrimitive representing a closed 2d region that can be supplied to addPrimitive. |
|
GraphicSolidPrimitive |
A GraphicPrimitive representing a SolidPrimitive to be supplied to addPrimitive. |
|
GraphicTemplate |
A reusable representation of a RenderGraphic. |
|
Instance |
Represents one repetition of a GraphicTemplate. |
|
InstancedGraphicParams |
Parameters for creating a RenderGraphic representing a collection of instances of shared geometry. |
|
InstanceSymbology |
Describes the appearance overrides to be applied to an Instance. |
|
MaterialDiffuseProps |
Describes the diffuse properties of a RenderMaterial. |
|
MaterialParams |
Describes a RenderMaterial. |
|
MaterialSpecularProps |
Describes the specular properties of a material. |
|
MaterialTextureMappingProps |
Describes how to map a RenderTexture's image to the surfaces to which a RenderMaterial is applied. |
|
MeshArgs |
Arguments supplied to createTriMesh describing a triangle mesh. |
|
ParticleCollectionBuilder |
Interface for producing a collection of particles suitable for use in particle effects. |
|
ParticleCollectionBuilderParams |
Parameters used to construct a ParticleCollectionBuilder. |
|
ParticleProps |
Describes a particle to to add to a particle collection via addParticle. |
|
PickableGraphicOptions |
Options used as part of GraphicBuilderOptions to describe a pickable RenderGraphic. |
|
PolylineArgs |
Arguments supplied to createIndexedPolylines describing a set of "polylines" (i.e., line strings or point strings). |
|
QueryScreenFeaturesOptions |
Options specifying how to query for visible Features by reading pixels rendered by a Viewport. |
|
QueryTileFeaturesOptions |
Options specifying how to query for visible Features by inspecting the Tiles selected for display by a Viewport. |
|
RealityMeshParams |
Geometry for a reality mesh to be submitted to the RenderSystem for conversion to a RenderGraphic. |
|
RealityMeshParamsBuilderOptions |
Options used to construct a RealityMeshParamsBuilder. |
|
RenderInstances |
Contains the WebGL resources necessary to draw multiple Instances of a GraphicTemplate using instanced rendering. |
|
RenderInstancesParams |
Represents a RenderInstances in a form that supports structured cloning, |
|
RenderInstancesParamsBuilder |
Provides methods to populate a RenderInstancesParams from a list of Instances. |
|
RenderSystemDebugControl |
An interface optionally exposed by a RenderSystem that allows control of various debugging features. |
|
ScreenSpaceEffectBuilder |
An interface used to construct and register with the renderSystem a custom screen-space effect. |
|
ScreenSpaceEffectBuilderParams |
Parameters used to create a ScreenSpaceEffectBuilder. |
|
ScreenSpaceEffectContext |
Context passed to shouldApply. |
|
ScreenSpaceEffectSource |
The GLSL implementation of the effect produced by a ScreenSpaceEffectBuilder, to be integrated into a complete shader program. |
|
TextureCacheOwnership |
Specifies that a RenderTexture should be kept in memory until the corresponding IModelConnection is closed, at |
|
TextureImage |
Describes the image from which to create a RenderTexture. |
|
Uniform |
Represents a uniform variable in a shader program used by a custom screen-space effect, providing methods for setting the current value of the uniform. |
|
UniformArrayParams |
Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program. |
|
UniformContext |
Context supplied to UniformParams.bind. |
|
UniformParams |
Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program. |
|
UpsampledRealityMeshParams |
|
|
ViewportGraphicBuilderOptions |
Options for creating a GraphicBuilder to produce a RenderGraphic to be displayed in a specific Viewport. |
|
VisibleFeature |
Represents a Feature determined to be visible within a Viewport. |
|
WorkerGraphicDescriptionContext |
Context allocated on a Worker to enable it to create GraphicDescriptions. |
|
WorkerGraphicDescriptionContextProps |
An opaque representation of a WorkerGraphicDescriptionContext that can be passed from the main thread to a Worker. |
|
WorkerTextureParams |
Parameters describing a RenderTexture to be created on a Worker by createTexture. |
|