SolidPrimitive Class

Base class for SolidPrimitive variants.

  • The base class holds capped flag for all derived classes.

Extends

Extended by

Methods

Name Description
constructor(capped: boolean): SolidPrimitive Protected    
constantVSection(_vFraction: number): undefined | CurveCollection Abstract Return a cross section at specified vFraction.  
getConstructiveFrame(): undefined | Transform Abstract Return a Transform from the local system of the solid to world.  

Inherited methods

Name Inherited from Description
clone(): undefined | GeometryQuery Abstract Inherited GeometryQuery Return a clone
cloneTransformed(transform: Transform): undefined | GeometryQuery Abstract Inherited GeometryQuery Return a transformed clone.
dispatchToGeometryHandler(handler: GeometryHandler): any Abstract Inherited GeometryQuery Double Dispatch call pattern.
extendRange(rangeToExtend: Range3d, transform?: Transform): void Abstract Inherited GeometryQuery Extend rangeToExtend by the range of this geometry multiplied by the transform.
isAlmostEqual(other: GeometryQuery): boolean Inherited GeometryQuery Test for exact structure and nearly identical geometry.
isSameGeometryClass(other: GeometryQuery): boolean Abstract Inherited GeometryQuery Test if (other instanceof this.Type).
range(transform?: Transform, result?: Range3d): Range3d Inherited GeometryQuery Return the range of the entire GeometryQuery tree.
tryTransformInPlace(transform: Transform): boolean Abstract Inherited GeometryQuery Attempt to transform in place.
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean Inherited GeometryQuery Try to move the geometry by dx,dy,dz.
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static Inherited GeometryQuery Apply instance method isAlmostEqual if both are defined.

Properties

Name Type Description
_capped Protected boolean Flag indicating whether cap region is considered closed (i.e.  
capped Accessor boolean Whether this is a capped solid.  
geometryCategory Readonly "solid" String name for schema properties.  
isClosedVolume Accessor Abstract ReadOnly boolean Return true if this is a closed volume  
solidPrimitiveType Abstract Readonly SolidPrimitiveType String name for schema properties.  

Inherited properties

Name Type Inherited from Description
children Accessor Inherited ReadOnly undefined | GeometryQuery[] GeometryQuery Return GeometryQuery children for recursive queries.
* leaf classes do not need to implement.

Defined in

Last Updated: 18 January, 2025