RuledSweep Class

A ruled sweep (surface) is a collection of 2 or more contours.

  • All contours must have identical number and type of geometry. (paths, loops, parity regions, lines, arcs, other curves).

Extends

Methods

Name Description
clone(): RuledSweep Return a deep clone.  
cloneContours(): CurveCollection[] Return clones of the sweep contours, each as a CurveCollection.  
cloneSweepContours(): SweepContour[] Return clones of the sweep contours.  
cloneTransformed(transform: Transform): undefined | RuledSweep Return a transformed clone.  
constantVSection(vFraction: number): undefined | CurveCollection Return the section curves at a fraction of the sweep.  
dispatchToGeometryHandler(handler: GeometryHandler): any Dispatch to strongly typed handler.handleRuledSweep(this).  
extendRange(rangeToExtend: Range3d, transform?: Transform): void Pass each contour to extendRange.  
getConstructiveFrame(): undefined | Transform Return a coordinate frame (right handed unit vectors)  
isAlmostEqual(other: GeometryQuery): boolean Test for near equality of two RuledSweeps.  
isSameGeometryClass(other: any): boolean Test if other is an instance of a RuledSweep.  
sweepContoursRef(): SweepContour[] Return a reference to the array of SweepContour.  
tryTransformInPlace(transform: Transform): boolean Transform all contours in place.  
create(contours: AnyCurve[], capped: boolean): undefined | RuledSweep Static Create a ruled sweep from an array of contours.  
mutatePartners(collectionA: CurveCollection, collectionB: CurveCollection, primitiveMutator: CurvePrimitiveMutator): undefined | CurveCollection Static Construct a CurveCollection with the same structure as collectionA and collectionB, with primitives constructed  

Inherited methods

Name Inherited from Description
range(transform?: Transform, result?: Range3d): Range3d Inherited SolidPrimitive Return the range of the entire GeometryQuery tree.
tryTranslateInPlace(dx: number, dy: number0.0, dz: number0.0): boolean Inherited SolidPrimitive Try to move the geometry by dx,dy,dz.
areAlmostEqual(a: GeometryQuery, b: GeometryQuery): boolean Static Inherited SolidPrimitive Apply instance method isAlmostEqual if both are defined.

Properties

Name Type Description
isClosedVolume Accessor ReadOnly boolean    
solidPrimitiveType Readonly "ruledSweep" String name for schema properties.  

Inherited properties

Name Type Inherited from Description
_capped Protected Inherited boolean SolidPrimitive Flag indicating whether cap region is considered closed (i.e.
capped Accessor Inherited boolean SolidPrimitive Whether this is a capped solid.
children Accessor Inherited ReadOnly undefined | GeometryQuery[] SolidPrimitive Return GeometryQuery children for recursive queries.
* leaf classes do not need to implement.
geometryCategory Readonly Inherited "solid" SolidPrimitive String name for schema properties.

Defined in

Last Updated: 18 January, 2025