Inputs
Components for working with input controls, such as Input, IconInput and NumberInput.
Classes
Name | Description | |
---|---|---|
InputLabel | Text input wrapper that provides additional styling and labeling | Deprecated |
Enumerations
Name | Description | |
---|---|---|
InputStatus | Enum for Input status | Deprecated |
Global Functions
Name | Description | |
---|---|---|
IconInput | ||
NumberInput |
Interfaces
Name | Description | |
---|---|---|
IconInputProps | Properties for the IconInput component | Deprecated |
InputLabelProps | Properties for InputLabel components | Deprecated |
LabeledComponentProps | Properties for labeled components | Deprecated |
Properties for components with messages | Deprecated | |
NumberInputProps | Properties for the NumberInput component | Deprecated |
Type Aliases
Name | Description | |
---|---|---|
StepFunctionProp | Step function prototype for NumberInput component | Deprecated |
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.