editor-frontend
Classes
Name | Description | |
---|---|---|
CreateElementTool | Placement tool base class for creating new elements. | |
CreateElementWithDynamicsTool | Placement tool base class for creating new elements that use dynamics to show intermediate results. | |
DynamicGraphicsProvider | A class for creating and managing a RenderGraphic for the purpose of interactive tool dynamics. | |
EditTools | Supports PrimitiveTool and InputCollector sub-classes. | |
ModifyElementTool | Edit tool base class for updating existing elements. | |
ModifyElementWithDynamicsTool | Edit tool base class for updating existing elements that use dynamics to show intermediate results. | |
ProjectExtentsClipDecoration | Controls to modify project extents shown using view clip | |
ProjectGeolocationMoveTool | Move a geolocated model by specifying two points to define the offset. | |
ProjectGeolocationNorthTool | Change or update geolocation direction to true north. | |
ProjectGeolocationPointTool | Change or update geolocation for project. | |
ProjectLocationCancelTool | Clear project location decoration. | |
ProjectLocationHideTool | Hide project location decoration. | |
ProjectLocationSaveTool | Save modified project extents and geolocation. | |
ProjectLocationShowTool | Show project location decoration. | |
RedoTool | Redo active tool steps, or element changes | |
TransformElementsTool | Edit tool base class for applying a transform to element placements. | |
TransformGraphicsProvider | A class for creating and managing RenderGraphics representing geometric elements for the purpose of interactive tool dynamics. | |
UndoAllTool | Undo all element changes | |
UndoTool | Undo active tool steps, or element changes |
Enumerations
Name | Description | |
---|---|---|
ProjectLocationChanged | Values for [[ProjectExtentsClipDecoration.onChanged] event. |
Global Functions
Name | Description | |
---|---|---|
computeChordToleranceFromPoint | Calculate a view based chord tolerance for facetting curved geometry given a world coordinate and optional radius. | |
computeChordToleranceFromRange | Calculate a view based chord tolerance for facetting curved geometry given a world coordinate range box. | |
makeEditToolIpc | Create a type safe Proxy object to make IPC calls from EditTools to methods of an EditCommandIpc interface of the current EditCommand . |
Interfaces
Name | Description | |
---|---|---|
TransformGraphicsData | Geometric element id, placement, and RenderGraphic managed by TransformGraphicsProvider. |
Namespaces
Name | Description | |
---|---|---|
EditTools |
Last Updated: 13 May, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.