ModifyElementTool Class
Edit tool base class for updating existing elements.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): ModifyElementTool | ||
acceptElementForOperation(id: string): Promise<boolean> Protected | ||
allowView(_vp: Viewport): boolean Protected | ||
applyAgendaOperation(ev: BeButtonEvent): Promise<boolean> Protected | ||
doAcceptElementForOperation(_id: string): Promise<boolean> Protected | ||
doUpdateElement(_props: GeometricElementProps): Promise<boolean> Protected | ||
getDragSelectCandidates(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<Id64Arg> Protected | Get element ids to process from drag box or crossing line selection. | |
getElementProps(ev: BeButtonEvent): undefined | GeometricElementProps Protected Abstract | ||
getGeometryProps(ev: BeButtonEvent, isAccept: boolean): undefined | JsonGeometryStream | FlatBufferGeometryStream Protected Abstract | ||
getGroupIds(id: string): Promise<Id64Arg> Protected | If the supplied element is part of an assembly, return all member ids. | |
getSelectionSetCandidates(ss: SelectionSet): Promise<Id64Arg> Protected | Get element ids to process from the active selection set. | |
isCompatibleViewport(vp: Viewport, isSelectedViewChange: boolean): boolean | Determine whether the supplied Viewport is compatible with this tool. | |
isElementValidForOperation(hit: HitDetail, out?: LocateResponse): Promise<boolean> Protected | Sub-classes should override to apply tool specific filtering and to provide an explanation for rejection. | |
onGeometryFilterChanged(): void Protected | ||
postFilterIds(arg: Id64Arg): Promise<Id64Arg> Protected | ||
processAgenda(ev: BeButtonEvent): Promise<void> | Sub-classes that require and use the accept point should override to apply the tool operation to ElementSetTool.agenda. | |
setupAccuDraw(): void Protected | ||
setupAndPromptForNextAction(): void Protected | Setup auto-locate, AccuSnap, AccuDraw, and supply tool assistance. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> Inherited | ElementSetTool | Used to receive property changes from UI. |
autoLockTarget(): void Inherited | ElementSetTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void Inherited | ElementSetTool | Call to initialize dynamics mode. |
buildDragSelectAgenda(vp: Viewport, origin: Point3d, corner: Point3d, method: SelectionMethod, overlap: boolean): Promise<boolean> Protected Inherited | ElementSetTool | Populate ElementSetTool.agenda by drag box or crossing line information. |
buildLocateAgenda(hit: HitDetail): Promise<boolean> Protected Inherited | ElementSetTool | Populate ElementSetTool.agenda from a HitDetail. |
buildSelectionSetAgenda(ss: SelectionSet): Promise<boolean> Protected Inherited | ElementSetTool | Populate ElementSetTool.agenda from a SelectionSet. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> Inherited | ElementSetTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | ElementSetTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean Inherited | ElementSetTool | Helper method for responding to a tool setting property value change by updating saved settings. |
chooseNextHit(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited | ElementSetTool | Allow reset to cycle between elements identified for overlapping the locate circle. |
decorate(context: DecorateContext): void Inherited | ElementSetTool | Show graphics for when drag selection is active. |
decorateSuspended(_context: DecorateContext): void Inherited | ElementSetTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
doLocate(ev: BeButtonEvent, newSearch: boolean): Promise<boolean> Protected Inherited | ElementSetTool | Identify an element and update the element agenda. |
doProcessSelectionSetImmediate(): Promise<void> Protected Inherited | ElementSetTool | Support either ElementSetTool.requireAcceptForSelectionSetOperation or ElementSetTool.requireAcceptForSelectionSetDynamics returning false. |
endDynamics(): void Inherited | ElementSetTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> Inherited | ElementSetTool | |
filterHit(hit: HitDetail, out?: LocateResponse): Promise<LocateFilterStatus> Inherited | ElementSetTool | Called from ElementSetTool.doLocate as well as auto-locate to accept or reject elements under the cursor. |
gatherElements(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected Inherited | ElementSetTool | Collect element input until tool has a sufficient number to complete. |
gatherInput(ev: BeButtonEvent): Promise<undefined | EventHandled> Protected Inherited | ElementSetTool | Collect point input until tool has a sufficient number to complete. |
getCurrentButtonEvent(ev: BeButtonEvent): void Inherited | ElementSetTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps Inherited | ElementSetTool | Called to allow snapping to pickable decoration geometry. |
getLocateCandidates(hit: HitDetail): Promise<Id64Arg> Protected Inherited | ElementSetTool | Get element id(s) to process from a HitDetail already accepted by ElementSetTool.isElementValidForOperation. |
getPrompt(): string Inherited | ElementSetTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> Inherited | ElementSetTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> Inherited | ElementSetTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initAgendaDynamics(): Promise<boolean> Protected Inherited | ElementSetTool | |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void Inherited | ElementSetTool | Helper method to establish initial values for tool setting properties from saved settings. |
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void Inherited | ElementSetTool | Helper method for tools that need to locate existing elements. |
isElementIdValid(id: string, source: ModifyElementSource): boolean Protected Inherited | ElementSetTool | Quick id validity check. |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean Inherited | ElementSetTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onAgendaModified(): Promise<void> Protected Inherited | ElementSetTool | Sub-classes can override to be notified of ElementSetTool.agenda changes by other methods. |
onCleanup(): Promise<void> Inherited | ElementSetTool | Make sure elements from ElementSetTool.agenda that aren't also from SelectionSet aren't left hilited. |
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the data button is pressed. |
onDataButtonUp(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the data button is released. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void Inherited | ElementSetTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> Inherited | ElementSetTool | Override to execute additional logic when tool is installed. |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> Inherited | ElementSetTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(_wentDown: boolean, modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> Inherited | ElementSetTool | Update prompts, cursor, graphics, etc. |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Support completing active drag selection on mouse end drag event and update ElementSetTool.agenda. |
onMouseMotion(ev: BeButtonEvent): Promise<void> Inherited | ElementSetTool | Make sure drag selection graphics are updated when mouse moves. |
onMouseStartDrag(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Support initiating drag selection on mouse start drag event when ElementSetTool.allowDragSelect is true. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the mouse wheel moves. |
onPostInstall(): Promise<void> Inherited | ElementSetTool | Setup initial element state, prompts, check SelectionSet, etc. |
onProcessComplete(): Promise<void> Protected Inherited | ElementSetTool | Sub-classes can override to continue with current ElementSetTool.agenda or restart after processing has completed. |
onRedoPreviousStep(): Promise<boolean> Inherited | ElementSetTool | Called to reinstate to a previous tool state (ex. |
onReinitialize(): Promise<void> Inherited | ElementSetTool | Exit and start default tool when ElementSetTool.isSelectionSetModify is true to allow SelectionSet to be modified, |
onResetButtonDown(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the reset button is pressed. |
onResetButtonUp(ev: BeButtonEvent): Promise<EventHandled> Inherited | ElementSetTool | Invoked when the reset button is released. |
onRestartTool(): Promise<void> Abstract Inherited | ElementSetTool | Called when an external event may invalidate the current tool's state. |
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> Inherited | ElementSetTool | Called when active view changes. |
onSuspend(): Promise<void> Inherited | ElementSetTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(_ev: BeTouchEvent): Promise<void> Inherited | ElementSetTool | Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches. |
onTouchComplete(_ev: BeTouchEvent): Promise<void> Inherited | ElementSetTool | Called when the last touch point is removed from the surface completing the current gesture. |
onTouchEnd(_ev: BeTouchEvent): Promise<void> Inherited | ElementSetTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(_ev: BeTouchEvent): Promise<void> Inherited | ElementSetTool | Called when a touch point moves along the surface. |
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> Inherited | ElementSetTool | Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap. |
onTouchStart(_ev: BeTouchEvent): Promise<void> Inherited | ElementSetTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> Inherited | ElementSetTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
onUndoPreviousStep(): Promise<boolean> Inherited | ElementSetTool | Called to reverse to a previous tool state (ex. |
onUnsuspend(): Promise<void> Inherited | ElementSetTool | Restore tool assistance after no longer being suspended by either a ViewTool or InputCollector. |
parseAndRun(..._args: string[]): Promise<boolean> Inherited | ElementSetTool | Run this instance of a tool using a series of string arguments. |
processAgendaImmediate(): Promise<void> Protected Inherited | ElementSetTool | Sub-classes that return false for ElementSetTool.requireAcceptForSelectionSetOperation should override to apply the tool operation to ElementSetTool.agenda. |
processDataButton(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited | ElementSetTool | Orchestrates advancing the internal state of the tool on a data button event. |
processResetButton(ev: BeButtonEvent): Promise<EventHandled> Protected Inherited | ElementSetTool | Orchestrates updating the internal state of the tool on a reset button event. |
provideToolAssistance(mainInstrText?: string, additionalInstr?: ToolAssistanceInstruction[]): void Protected Inherited | ElementSetTool | Sub-classes should override to provide tool specific instructions. |
reloadToolSettingsProperties(): void Inherited | ElementSetTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
requireWriteableTarget(): boolean Inherited | ElementSetTool | Called from isCompatibleViewport to check for a read only iModel, which is not a valid target for tools that create or modify elements. |
run(..._args: any[]): Promise<boolean> Inherited | ElementSetTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> Inherited | ElementSetTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
selectByPointsDecorate(context: DecorateContext): void Protected Inherited | ElementSetTool | Display drag box and crossing line selection graphics. |
selectByPointsEnd(ev: BeButtonEvent): Promise<boolean> Protected Inherited | ElementSetTool | Finish drag selection and update ElementSetTool.agenda with any elements that may have been identified. |
selectByPointsStart(ev: BeButtonEvent): Promise<boolean> Protected Inherited | ElementSetTool | Initiate tool state for start of drag selection. |
setPreferredElementSource(): void Protected Inherited | ElementSetTool | Whether tool should operate on an existing selection set or instead prompt user to identity elements. |
supplyToolSettingsProperties(): undefined | DialogItem[] Inherited | ElementSetTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void Inherited | ElementSetTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean Inherited | ElementSetTool | Called to support operations on pickable decorations, like snapping. |
useOverlapSelection(ev: BeButtonEvent): boolean Protected Inherited | ElementSetTool | Whether drag box selection only identifies elements that are wholly inside or also allows those that overlap |
wantProcessAgenda(_ev: BeButtonEvent): boolean Protected Inherited | ElementSetTool | Whether the tool is ready for ElementSetTool.processAgenda to be called to complete the tool operation. |
register(namespace?: string): void Static Inherited | ElementSetTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
_checkedIds Protected Readonly | Map<string, boolean> |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
agenda Accessor Protected Inherited ReadOnly | ElementAgenda | ElementSetTool | Get the ElementAgenda the tool will operate on. |
allowDragSelect Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to allow element identification by drag box or crossing line selection. |
allowGroups Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Support operations on groups/assemblies independent of selection scope. |
allowSelectionSet Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether ElementSetTool.agenda should be populated from an active selection set. |
anchorPoint Protected Inherited | Point3d | undefined | ElementSetTool | The accept point for a selection set, drag select, or final located element. |
briefcase Accessor Inherited ReadOnly | undefined | BriefcaseConnection | ElementSetTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target ElementSetTool.iModel is a briefcase. |
clearSelectionSet Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to clear the active selection set for tools that return false for ElementSetTool.allowSelectionSet. |
controlKeyContinuesSelection Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to continue selection of additional elements by holding the ctrl key down. |
controlKeyInvertsSelection Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to invert selection of elements identified with the ctrl key held down. |
currentElementCount Accessor Protected Inherited ReadOnly | number | ElementSetTool | Convenience method to get current count from ElementSetTool.agenda. |
description Accessor Inherited ReadOnly | string | ElementSetTool | Get the localized description string from this Tool's class |
description Accessor Static Inherited ReadOnly | string | ElementSetTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ElementSetTool.flyover is returned. |
dragStartPoint Protected Inherited | Point3d | undefined | ElementSetTool | The button down location that initiated box or crossing line selection. |
englishKeyin Accessor Static Inherited ReadOnly | string | ElementSetTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor Inherited ReadOnly | string | ElementSetTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static Inherited ReadOnly | string | ElementSetTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ElementSetTool.keyin is returned. |
hidden Static Inherited | boolean | ElementSetTool | If true, this Tool will not appear in the list from ToolRegistry.getToolList. |
iconSpec Accessor Inherited ReadOnly | string | ElementSetTool | Get the iconSpec from this Tool's class. |
iconSpec Static Inherited | string | ElementSetTool | The icon for this Tool. |
iModel Accessor Inherited ReadOnly | IModelConnection | ElementSetTool | Get the iModel on which this tool operates. |
isControlDown Accessor Inherited ReadOnly | boolean | ElementSetTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor Inherited ReadOnly | boolean | ElementSetTool | Call to find out if dynamics are currently active. |
isSelectByPoints Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether drag box or crossing line selection is currently active. |
isSelectionSetModify Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether original source of elements being modified was the active selection set. |
keyin Accessor Inherited ReadOnly | string | ElementSetTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static Inherited ReadOnly | string | ElementSetTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor Static Inherited ReadOnly | undefined | number | ElementSetTool | The maximum number of arguments allowed by ElementSetTool.parseAndRun, or undefined if there is no maximum. If subclasses override ElementSetTool.parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor Static Inherited ReadOnly | number | ElementSetTool | The minimum number of arguments allowed by ElementSetTool.parseAndRun. If subclasses override ElementSetTool.parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static Inherited | string | ElementSetTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent Inherited | boolean | ElementSetTool | Used to avoid sending tools up events for which they did not receive the down event. |
requireAcceptForSelectionSetDynamics Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to begin dynamics for a selection set immediately or wait for a data button. |
requireAcceptForSelectionSetOperation Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether a selection set should be processed immediately upon installation or require a data button to accept. |
requiredElementCount Accessor Protected Inherited ReadOnly | number | ElementSetTool | Minimum required number of elements for tool to be able to complete. |
shouldEnableLocate Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | |
shouldEnableSnap Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | |
targetIsLocked Inherited | boolean | ElementSetTool | |
targetModelId Accessor Inherited | undefined | string | ElementSetTool | |
targetView Inherited | Viewport | undefined | ElementSetTool | The viewport within which the tool operates. |
toolId Accessor Inherited ReadOnly | string | ElementSetTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolId Static Inherited | string | ElementSetTool | The unique string that identifies this tool. |
wantAccuSnap Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether ElementSetTool.setupAndPromptForNextAction should call AccuSnap.enableSnap for current tool phase. |
wantAdditionalElements Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether tool is done identifying elements and is ready to move to the next phase. |
wantAdditionalInput Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether the tool has gathered enough input to call ElementSetTool.processAgenda. Sub-classes should override to check for additional point input they collected in ElementSetTool.wantProcessAgenda. |
wantDynamics Accessor Protected Inherited ReadOnly | boolean | ElementSetTool | Whether to automatically start element dynamics after all required elements have been identified. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.