components-react
Classes
Name | Description | |
---|---|---|
AbstractTreeNodeLoader | Abstract node loader implementation which loads nodes into provided model source. | |
AbstractTreeNodeLoaderWithProvider | Abstract node loader with tree data provider which loads nodes into provided model source. | |
ActionButtonList | ActionButtonList React component. | |
ArrayPropertyValueRenderer | Default Array Property Renderer | |
BasePointTypeConverter | Point type converter. | |
BasicPropertyEditor | Basic Property Editor registered for the "text" and "string" type names. | |
BooleanEditor | BooleanEditor React component that is a property editor with checkbox input | |
BooleanPropertyEditor | Boolean Property Editor registered for the "bool" and "boolean" type names. | |
BooleanTypeConverter | Boolean Type Converter. | |
CompositePropertyDataFilterer | Composite PropertyData filter which can join two filters using logic operators | |
CompositeTypeConverter | Composite type converter | |
DataControllerBase | DataControllerBase is the base class for all Data Controllers. | |
DateTimeTypeConverter | Date Time Type Converter. | |
DateTimeTypeConverterBase | DateTime Type Converter. | |
DisplayValuePropertyDataFilterer | Property data filterer which matches on Primitive Property Record display value text. | |
DoublePropertyValueRenderer | Default Double Property Renderer | Deprecated |
EnumButtonGroupEditor | EnumButtonGroupEditor React component that is a property editor with select input | |
EnumEditor | EnumEditor React component that is a property editor with select input | |
EnumPropertyButtonGroupEditor | Enum Property Button Group Editor registered for the "enum" type name and the "enum-buttongroup" editor name. | |
EnumPropertyEditor | Enum Property Button Group Editor registered for the "enum" type name. | |
EnumTypeConverter | Enum Type Converter. | |
FavoritePropertiesRenderer | Renderer for Favorite Property List | |
FilteringInput | A helper component for filtering trees and stepping through results | |
FilteringPropertyDataProvider | IPropertyDataProvider implementation which filters wrapped provider PropertyData using passed IPropertyDataFilterer. | |
FloatTypeConverter | Float Type Converter. | |
HexadecimalTypeConverter | Hexadecimal Type Converter. | |
HighlightingEngine | Tree highlighting engine | |
ImageCheckBoxEditor | ImageCheckBoxEditor | |
ImageCheckBoxPropertyEditor | ImageCheckBox Property Editor registered for the "bool" and "boolean" type names. | |
IntTypeConverter | Int Type Converter. | |
LabelPropertyDataFilterer | PropertyData filter which matches on any record type label and includes descendant nodes on match | |
MergedPropertyValueRenderer | Default Merged Property Renderer | |
MutableCategorizedArrayProperty | Mutable wrapper object for PropertyRecord with array valueFormat which provides methods for working with and managing record children hierarchies. | |
MutableCategorizedPrimitiveProperty | Mutable wrapper object for PropertyRecord with primitive valueFormat. | |
MutableCategorizedProperty | Base class for all Mutable CategorizedProperties | |
MutableCategorizedStructProperty | Mutable wrapper object for PropertyRecord with struct valueFormat which provides methods for working with and managing record children hierarchies. | |
MutableFlatPropertyGridItem | Base class for all FlatPropertyGrid items | |
MutableGridCategory | Mutable wrapper object for PropertyCategory which provides methods for working with and managing category and record children hierarchies | |
MutableGridItemFactory | Implementation of IMutableGridItemFactory for creating MutableGridItem objects. | |
MutablePropertyGridModel | Implementation of PropertyGridModel for working with and converting PropertyData to mutable FlatGridItems | |
MutableTreeModel | Mutable tree model which holds nodes and allows adding or removing them. | |
NavigationPropertyTypeConverter | Navigation property type converter. | |
NavigationPropertyValueRenderer | Default Navigation Property Renderer | Deprecated |
NonPrimitivePropertyLabelRenderer | A React component that renders a non-primitive property label. | |
NonPrimitivePropertyRenderer | React Component that renders struct and array properties | |
NumericInputEditor | NumericInputEditor React component that is a property editor with numeric input & up/down buttons | |
NumericInputPropertyEditor | Numeric Input Property Editor registered for the "number" type name and "numeric-input" editor name. | |
NumericTypeConverterBase | Base Numeric Type Converter. | |
PagedTreeNodeLoader | Default paged tree node loader with TreeDataProvider implementation. |
|
Point2dTypeConverter | Point2d type converter. | |
Point3dTypeConverter | Point3d type converter. | |
PrimitivePropertyLabelRenderer | A React component that renders a primitive property label | |
PrimitivePropertyRenderer | React Component that renders primitive properties | |
PrimitivePropertyValueRenderer | Default Primitive Property Renderer | |
PropertyCategoryBlock | PropertyCategoryBlock React component | |
PropertyCategoryDataFiltererBase | An abstract implementation of IPropertyDataFilterer that can be used as base for all | |
PropertyCategoryLabelFilterer | PropertyData filterer which matches on PropertyCategory's label. | |
PropertyCategoryRendererManager | Keeps a record of currently registered property category renderers and determines which renderers get invoked for | |
PropertyDataChangeEvent | An event broadcasted on property data changes | |
PropertyDataFiltererBase | An abstract implementation of IPropertyDataFilterer to share common behavior between different implementations. | |
PropertyEditorBase | PropertyEditor is the base class for all property editors. | |
PropertyEditorManager | Manages Property Editors. | |
PropertyFilterBuilderActions | Actions for controlling PropertyFilterBuilder component state. | |
PropertyFilterChangeEvent | An event broadcasted when property filter changes | |
PropertyGridEventHandler | Handles events and changes on PropertyGridModel data. | |
PropertyGridModelChangeEvent | An event broadcasted on property grid model changes | |
PropertyGridModelSource | Controls property grid model. | |
PropertyList | A React component that renders multiple properties within a category as a list. | |
PropertyRecordDataFiltererBase | An abstract implementation of IPropertyDataFilterer that can be used as base for all | |
PropertyValueRendererManager | Default implementation of property value renderer manager | |
PropertyView | A React component that renders property as label/value pair | |
ResultSelector | Component for stepping through results/entries | |
ShortDateTypeConverter | Short Date Type Converter. | |
SimplePropertyDataProvider | Implementation of [IPropertyDataProvider] that uses an associative array. | |
SimpleTreeDataProvider | A tree data provider using SimpleTreeDataProviderHierarchy. | |
SliderEditor | SliderEditor React component that is a property editor with numeric input & up/down buttons | |
SliderPropertyEditor | Slider Property Editor registered for the "number" type name and "slider" editor name. | |
SparseArray | Structure for sparse array value storage. | |
StringTypeConverter | String Type Converter. | |
StructPropertyValueRenderer | Default Struct Property Renderer | |
TableArrayValueRenderer | A react component which renders array property value as a button with text | |
TableNonPrimitiveValueRenderer | A React component that renders non primitive values as a button with text. | |
TableStructValueRenderer | A react component which renders struct property value as a button with text | |
TextareaEditor | TextareaEditor React component that is a property editor with text input | |
TextareaPropertyEditor | Textarea Property Editor registered for the "text" and "string" type names and "multi-line" editor name. | |
TextEditor | TextEditor React component that is a property editor with text input | |
ToggleEditor | ToggleEditor React component that is a property editor with checkbox input | |
TogglePropertyEditor | Toggle Property Editor registered for the "bool" and "boolean" type names and "toggle" editor name. | |
TreeEventHandler | Default tree event handler. | |
TreeImageLoader | Default image loader for the tree | |
TreeModelSource | Controls tree model. | |
TreeNodeLoader | Default tree node loader with TreeDataProvider implementation. |
|
TreeRenderer | Default tree rendering component. | |
TypeConverter | Type Converter base class. | |
TypeConverterManager | Manages Type Converters. | |
UiComponents | Manages the localization service for the components-react package. | |
UrlPropertyValueRenderer | URL property value renderer that renders the whole value as a URL without matching it | |
VirtualizedPropertyGrid | VirtualizedPropertyGrid React component. |
Constants
Name | Description | |
---|---|---|
CheckBoxState | State of a checkbox. | |
DEFAULT_LINKS_HANDLER | Default link handler used for handling records, | |
ItemStyleProvider | Style provider for stylable items like TreeNodeItem | |
Orientation | Enumeration of orientation. | |
TableRowStyleProvider | Style provider for table rows | |
TimeFormat | Enumeration of time formats. | |
ToolbarPopupAutoHideContext | Context used by Toolbar items to know if popup panel should be hidden - via AutoHide. | |
ToolbarPopupContext | Context used by Toolbar items in popups to close the popup panel. | Deprecated |
Enumerations
Name | Description | |
---|---|---|
CompositeFilterType | Logical operator for composite filterer. | |
Direction | Available directions. | |
FilteredType | Enumeration of possible component filtered types | |
FilteringInputStatus | Enumeration of possible component contexts | |
FlatGridItemType | Types of FlatGridItems for differentiating what property FlatGridItem is wrapping. | |
PropertyContainerType | Types of property containers | |
PropertyFilterRuleGroupOperator | Logical operator for joining rules. | |
PropertyFilterRuleOperator | Operators for comparing property value in PropertyFilterRule. | |
SelectionMode | Selection modes for Tree row selection | |
SelectionModeFlags | Selection mode flags for Tree row selection | |
ToolbarOpacitySetting | Enumeration of Toolbar Opacity setting. | |
ToolbarPanelAlignment | Available alignment modes of Toolbar panels. |
Global Functions
Name | Description | |
---|---|---|
adjustDateToTimezone | Adjust a Date object to show time in one time zone as if it is in the local time zone. | |
computeVisibleNodes | Generates flat list of visible nodes in the tree model. | |
ControlledSelectableContent | A fully-controlled component that accepts a list of child components with ids and labels and | |
ControlledTree | React tree component which rendering is fully controlled from outside. | |
CustomizablePropertyRenderer | React Component that renders customizable properties | |
defaultPropertyFilterBuilderRuleValidator | Default rule validator. | Deprecated |
EditorContainer | EditorContainer React component used by the Tree and PropertyGrid for cell editing. | |
from | Helper method that creates an Observable from Iterable or Promise. | |
getPropertyFilterBuilderOperators | Function that returns set of available operator based on property type. | |
getVisibleDescendants | Traverses the tree and collects visible descendants. | |
hasChildren | Determines whether node has children | |
hasSelectionModeFlag | Determines if a SelectionMode is active | |
HighlightedText | Highlighted text | |
isPropertyFilterBuilderRuleGroup | Function to check if supplied PropertyFilterBuilderRuleGroupItem is PropertyFilterBuilderRuleGroup. | |
isPropertyFilterRuleGroup | Function that checks if supplied filter is rule group. | |
isTreeDataProviderInterface | Checks if TreeDataProvider is an ITreeDataProvider | |
isTreeDataProviderMethod | Checks if TreeDataProvider is a TreeDataProviderMethod | |
isTreeDataProviderPromise | Checks if TreeDataProvider is a TreeDataProviderPromise | |
isTreeDataProviderRaw | Checks if TreeDataProvider is a TreeDataProviderRaw | |
isTreeModelNode | Checks if object is TreeModelNode | |
isTreeModelNodePlaceholder | Checks if object is TreeModelNodePlaceholder | |
isTreeModelRootNode | Checks if object is TreeModelRootNode | |
isUnaryPropertyFilterBuilderOperator | Function that checks if supplied PropertyFilterBuilderRuleOperator operator is unary. | |
isUnaryPropertyFilterOperator | Function that checks if supplied PropertyFilterRuleOperator operator is unary. | |
LinksRenderer | React component for rendering string with links. | |
matchLinks | Returns a list of links from a text | |
ParsedInput | Generic Input component that requires formatting and parsing functions to be passed in as props. | |
PopupItem | Popup toolbar item that displays a panel. | Deprecated |
PopupItemWithDrag | Expandable group button item with drag. | Deprecated |
PropertyFilterBuilder | Component for building complex filters. | |
PropertyFilterBuilderLogicalOperator | Component to render the operator inside of the filter builder | |
PropertyFilterBuilderRenderer | Renderer for PropertyFilterBuilder component. | |
PropertyFilterBuilderRuleValue | Component that renders PropertyFilterBuilderRuleRenderer value input. | |
PropertyFilterBuilderToolbar | Toolbar displaying the "add" and "delete" row buttons in the filter builder | |
PropertyRenderer | A React component that renders properties | |
renderLinks | Renders anchor tag by wrapping or splitting provided text | |
SelectableContent | An uncontrolled component that accepts a list of child components with ids and labels and | |
toDateString | Format a date in a display string, optionally converting to time zone, if specified by timeZoneOffset | |
Toolbar | Component that displays toolbar items. | Deprecated |
ToolbarButtonItem | Toolbar item component. | |
ToolbarWithOverflow | Component that displays toolbar items, displaying only the elements that can fit in the available space, | Deprecated |
toTimeString | Format the time included in a date, optionally converting to time zone, if specified | |
TreeNodeContent | React component for displaying TreeNode label | |
TreeNodeEditor | React component for displaying tree node editor. | |
TreeNodeIcon | React component that renders icon for TreeNode. | |
TreeNodeRenderer | Default component for rendering tree node. | |
useAsyncValue | Custom hook for working with possibly async values. | |
useControlledTreeEventsHandler | Custom hook which creates and takes care of disposing a TreeEventHandler. | |
useControlledTreeLayoutStorage | Returns callbacks for persisting and restoring ControlledTree layout state. | |
useDebouncedAsyncValue | Custom hook for working with promise values. | |
useDefaultPropertyFilterBuilderRuleValidator | Creates default rule validator. | |
useDragInteraction | Hook used on expandable item that require drag or long press to open | |
usePagedTreeNodeLoader | Custom hook which creates a paging nodes' loader using the supplied data provider and model source. | |
usePropertyData | Custom hook that gets PropertyData from given IPropertyDataProvider and subscribes to further data changes. | |
usePropertyFilterBuilder | Custom hook that creates state for PropertyFilterBuilder component. | |
usePropertyGridEventHandler | Custom hook that creates memoized version of PropertyGridEventHandler that modifies given modelSource | |
usePropertyGridModel | Custom hook that automatically listens and retrieves latest model from model source | |
usePropertyGridModelSource | Custom hook that creates a PropertyGridModelSource and subscribes it to data updates from the data provider. | Deprecated |
useToolbarPopupAutoHideContext | React hook used to retrieve the ToolbarPopupAutoHideContext. | |
useToolbarPopupContext | React hook used to retrieve the ToolbarPopupContext. | Deprecated |
useTrackedPropertyGridModelSource | Custom hook that creates a PropertyGridModelSource and subscribes it to data updates from the data provider while also providing information on data update progress. | |
useTreeEventsHandler | Custom hook which creates and takes care of disposing a TreeEventsHandler. | Deprecated |
useTreeModel | React hook that returns an immutable TreeModel whenever it changes in the given |
|
useTreeModelSource | Custom hook which creates a TreeModelSource . |
|
useTreeNodeLoader | Custom hook which creates a nodes' loader using the supplied data provider and model source. | |
useVirtualizedPropertyGridLayoutStorage | Returns callbacks for persisting and restoring VirtualizedPropertyGrid layout state. | |
VirtualizedPropertyGridWithDataProvider | VirtualizedPropertyGrid React Component which takes a data provider and | |
withContextStyle | Wraps a React component with a span element with a given style attribute | |
withLinks | If record has links, wraps stringValue in them, otherwise returns unchanged stringValue |
Interfaces
Name | Description | |
---|---|---|
ActionButtonListProps | Properties of ActionButtonList React component | |
ActionButtonRendererProps | Properties of ActionButtonRenderer | |
ActiveMatchInfo | Properties for identifying an active highlight on a node in a tree. | |
Asynchronous Error Message returned as part of AsyncValueProcessingResult | ||
AsyncValueProcessingResult | Asynchronous Value Process Result | |
BuildFilterOptions | Options for buildFilter. | |
CategorizedPropertyItem | Data structure which describes methods and properties present on immutable CategorizedPropertyItem objects | |
CategoryRecordsDict | Category name to PropertyRecord[] key pair interface used to describe which records belong to which category. | |
CheckBoxInfo | Immutable data structure that describes checkbox info. | |
CheckboxStateChange | Data structure that describes checkbox state change. | |
CommonPropertyGridProps | Common Property Grid Props to be used by Property Grid Variants | |
CompletionObserver | CompletionObserver interface compatible with rxjs | |
ControlledSelectableContentProps | ControlledSelectableContent component properties | Deprecated |
ControlledTreeProps | Properties for ControlledTree | |
CustomToolbarItem | Describes the data needed to insert a custom React button into an ToolbarWithOverflow. |
Deprecated |
DataController | DataControllers can be implemented per typename to validate and commit values. | |
DateFormatOptions | Define formatting options for use when component are generating a formatted date string calling Date.toLocaleTimeString() . |
|
DelayLoadedTreeNodeItem | A TreeNodeItem for delay-loaded trees | |
EditableTreeDataProvider | EditableTreeDataProvider provides cell editing processing for the Tree. | |
EditorContainerProps | EditorContainer React component properties | Deprecated |
ErrorObserver | ErrorObserver interface compatible with rxjs | |
FilteredPropertyData | Data returned by FilteringPropertyDataProvider | |
FilteringInputProps | FilteringInput React Component properties | |
FlatGridItemBase | Base immutable data structure defining common methods and properties for categories and categorized properties | |
GridCategoryItem | Data structure which describes methods and properties present on immutable GridCategoryItem | |
HighlightableTreeNodeProps | Properties for a highlightable TreeNode | |
HighlightableTreeProps | Properties for highlighting nodes in a tree. | |
HighlightedTextProps | Properties of HighlightedText | Deprecated |
HighlightInfo | Item highlight info used for identification of a specific highlight in an item | |
HighlightingComponentProps | Properties used for highlighting parts in item by given text and actively highlighting one highlight in a distinct item specified in activeHighlight |
|
IImageLoader | Interface for an image loader. | |
ImmediatelyLoadedTreeNodeItem | A TreeNodeItem for immediately loaded trees | |
IMutableCategorizedPropertyItem | Data structure which describes methods and properties to be held by Mutable CategorizedPropertyItems | |
IMutableFlatPropertyGridItem | Base mutable data structure defining common methods and properties for both CategorizedProperties and GridCategoryItems | |
IMutableGridCategoryItem | Data structure which describes methods and properties to be held by Mutable GridCategoryItems | |
IMutableGridItemFactory | IMutableGridItemFactory interface for creating MutableGridItem objects | |
IMutablePropertyGridModel | PropertyGridModel interface for working with mutable FlatGridItems | |
IPropertyDataFilterer | An interface for a filterer that filters PropertyData based on content of PropertyRecord | |
IPropertyDataProvider | An interface for property data provider which returns | |
IPropertyGridEventHandler | Handles events and changes on PropertyGridModel data. | |
IPropertyGridModel | PropertyGridModel interface for working with immutable FlatGridItems | |
IPropertyGridModelSource | ||
IPropertyValueRenderer | Custom property value renderer interface | |
ItemColorOverrides | Color overrides for styled item | |
ItemStyle | Style properties for styled item like TreeNodeItem | |
ITreeDataProvider | Interface for a tree data provider class | |
ITreeImageLoader | Interface for a tree image loader | |
ITreeNodeLoader | Tree node loader which is used to load tree nodes. | |
ITreeNodeLoaderWithProvider | Tree node loader which uses TreeDataProvider to load nodes. |
|
LessGreaterOperatorProcessor | Operators for Numeric types, DateTime, TimeSpan, or any type that supports these comparisons | |
LinksRendererProps | Properties for LinksRenderer component. | Deprecated |
LoadedBinaryImage | Image data for raw images | |
LoadedImage | Image data for string based images | |
LoadedNodeHierarchy | Data structure that describes hierarchy loaded for parent node. | |
LoadedNodeHierarchyItem | Data structure that describes one loaded hierarchy item. | |
MutableCheckBoxInfo | Mutable data structure that describes checkbox info. | |
MutableTreeModelNode | Mutable data structure that describes tree node. | |
NextObserver | NextObserver interface compatible with rxjs | |
NonPrimitivePropertyLabelRendererProps | Properties for the NonPrimitivePropertyLabelRenderer React component | |
NonPrimitivePropertyRendererProps | Properties of NonPrimitivePropertyRenderer React component | |
NullableOperatorProcessor | Operators for all filterable null-able types | |
Observable | Observable interface compatible with rxjs | |
OperatorProcessor | Operators for all filterable types | |
PageOptions | Paging options. | |
ParsedInputProps | Props for ParsedInput control | Deprecated |
PopupItemProps | Properties of PopupItem component. | Deprecated |
PopupItemWithDragProps | Properties of PopupItemWithDrag component. | Deprecated |
PrimitivePropertyLabelRendererProps | Properties of a PrimitivePropertyLabelRenderer React component | |
PrimitiveRendererProps | Properties of PrimitivePropertyRenderer React component | |
PropertyCategory | Contains metadata about a group of Properties. | |
PropertyCategoryBlockProps | Properties for the PropertyCategoryBlock React component | |
PropertyCategoryRendererProps | Props that property category renderer receives. | |
PropertyData | Interface for property data provided to the PropertyGrid React component. | |
PropertyDataFilterResult | Data structure for storing IPropertyDataFilterer matching results | |
PropertyDialogState | State of the Dialog component in a container which renders properties | |
PropertyEditingArgs | Arguments for the Property Editing event callback | |
PropertyEditorProps | Properties for a property editor component | |
PropertyFilterBuilderLogicalOperatorProps | Props for PropertyFilterBuilderLogicalOperator component. | |
PropertyFilterBuilderProps | Props for PropertyFilterBuilder component. | |
PropertyFilterBuilderRendererProps | Props for PropertyFilterBuilderRenderer component. | |
PropertyFilterBuilderRule | Data structure that describes PropertyFilterBuilder component single rule. | |
PropertyFilterBuilderRuleGroup | Data structure that describes PropertyFilterBuilder component rule group. | |
PropertyFilterBuilderRuleOperatorProps | Props for PropertyFilterBuilderRuleOperator component. | |
PropertyFilterBuilderRuleRangeValue | Data structure that describes range value. | |
PropertyFilterBuilderRuleValueProps | Props for PropertyFilterBuilderRuleValue component. | |
PropertyFilterBuilderRuleValueRendererProps | Props for custom PropertyFilterBuilderRuleValue renderer. | |
PropertyFilterBuilderState | Data structure that describes PropertyFilterBuilder component state. | |
PropertyFilterRule | Data structure that describes single filter rule. | |
PropertyFilterRuleGroup | Data structure that describes group of filter rules. | |
PropertyGridContentHighlightProps | Properties for highlighting text in property grid. | |
PropertyGridContextMenuArgs | Arguments for PropertyGridProps.onPropertyContextMenu callback |
|
PropertyLabelRendererProps | Base properties for a property label renderer | |
PropertyListProps | Properties of PropertyList React component | |
PropertyPopupState | State of the Popup component in a container which renders properties | |
PropertyRendererProps | Properties of PropertyRenderer React component | |
PropertyUpdatedArgs | Arguments for the Property Updated event callback | |
PropertyValueRendererContext | Additional parameters to the renderer | |
PropertyViewProps | Properties of PropertyView React component | |
RenderedItemsRange | Data structure that describes range of rendered items in the tree. | |
ResultSelectorProps | ResultSelector React Component properties | |
SelectableContentDefinition | A definition for content displayed in ControlledSelectableContent and | |
SelectableContentProps | SelectableContent component properties | Deprecated |
SharedRendererProps | Properties shared by all renderers and PropertyView | |
SharedTableNonPrimitiveValueRendererProps | Shared properties between table non-primitive value renderers | |
SortComparer | Sort compare method for types that support sorting | |
StringOperatorProcessor | Operators for string types | |
Subscribable | Subscribable interface compatible with rxjs | |
Subscription | Subscription interface compatible with rxjs | |
TableNonPrimitiveValueRendererProps | Properties for TableNonPrimitiveValueRenderer React component | |
TableSpecificValueRendererProps | Properties for TableArrayValueRenderer and TableStructValueRenderer React component | |
ToolbarButtonItemProps | Properties of ToolbarButtonItem component. | |
ToolbarPopupContextProps | Deprecated | |
ToolbarProps | Properties of Toolbar component. | Deprecated |
ToolbarWithOverflowProps | Properties of ToolbarWithOverflow component. | Deprecated |
TreeActions | Tree actions that can be performed on tree. | |
TreeCheckboxStateChangeEventArgs | Data structure that describes tree checkbox state change event payload. | |
TreeEditingParams | Params used for tree node editing. | |
TreeEventHandlerParams | Data structure that describes tree event handler params. | |
TreeEvents | Tree events that can occur while interacting with tree. | |
TreeModel | Data structure that describes tree model. | |
TreeModelChanges | Data structure that describes changes which happened to the tree model | |
TreeModelNode | Immutable data structure that describes tree node. | |
TreeModelNodeEditingInfo | Data structure that holds callbacks used for tree node editing. | |
TreeModelNodeInput | Data structure that describes input used to create tree node. | |
TreeModelNodePlaceholder | Data structure that describes tree node placeholder. | |
TreeModelRootNode | Data structure that describes tree root node. | |
TreeNodeContentProps | Properties for TreeNodeContent component | Deprecated |
TreeNodeEditorProps | Properties for TreeNodeEditor component. | |
TreeNodeEventArgs | Data structure that describes tree node event payload. | |
TreeNodeIconProps | Props for TreeNodeIcon component. | Deprecated |
TreeNodeItem | A node item which can be displayed in a tree. | |
TreeNodeLoadResult | Data structure that describes node load result | |
TreeNodeRendererProps | Properties for TreeNodeRenderer. | |
TreeRendererAttributes | Attributes found on TreeRenderer component | |
TreeRendererProps | Properties for TreeRenderer component. | |
TreeSelectionChange | Data structure that describes tree selection change. | |
TreeSelectionModificationEventArgs | Data structure that describes tree selection modification event payload. | |
TreeSelectionReplacementEventArgs | Data structure that describes tree selection replacement event payload. | |
TypeEditor | Interface implemented by React based type editors | |
Unsubscribable | Unsubscribable interface compatible with rxjs | |
UsePropertyFilterBuilderProps | Props for usePropertyFilterBuilder | |
UsePropertyFilterBuilderResult | Type for usePropertyFilterBuilder return object. | |
VirtualizedPropertyGridContext | Context of the surrounding VirtualizedPropertyGrid component. | |
VirtualizedPropertyGridProps | Properties for VirtualizedPropertyGrid React component | |
VirtualizedPropertyGridWithDataProviderProps | Properties for VirtualizedPropertyGridWithDataProvider React component | Deprecated |
VisibleTreeNodes | Data structure that describes set of visible tree nodes as a flat list. |
Namespaces
Name | Description | |
---|---|---|
ConvertedPrimitives | Converted Primitives namespace | |
PropertyFilterBuilderRuleRangeValue |
Type Aliases
Name | Description | |
---|---|---|
ActionButtonRenderer | Renders a React component (usually a button) for a PropertyRecord | |
CategorizedPropertyTypes | Type which extracts FlatGridItemTypes relevant for working with CategorizedProperties | |
CheckBoxState | State of a checkbox. | |
FlatGridItem | Type which describes immutable GridCategoryItem or CategorizedPropertyItem | |
Image | Image data returned by an IImageLoader | |
ImageFileFormat | Type of raw image format | |
ImageSourceType | Type of loaded image source: | |
IMutableFlatGridItem | Type which describes mutable GridCategoryItem or CategorizedProperty | |
Observer | Observer interface compatible with rxjs | |
OnItemsDeselectedCallback | Called after items were deselected. | |
OnItemsSelectedCallback | Called after items were selected. | |
OnSelectionChanged | Prototype for a Selection Changed handler | |
Orientation | Enumeration of orientation. | |
PropertyCategoryRenderer | Factory function that produces custom property category components. | |
PropertyDataChangesListener | A signature for property data change listeners | |
PropertyFilter | Type that describes property filter. | |
PropertyFilterBuilderRuleGroupItem | Type that describes PropertyFilterBuilder component group item. | |
PropertyFilterBuilderRuleOperator | Operators supported by usePropertyFilterBuilder when building filter rules. | |
PropertyFilterChangesListener | A signature for property data change listeners | |
PropertyGridModelChangeListener | A signature for property grid model change listeners | |
SimpleTreeDataProviderHierarchy | Used by SimpleTreeDataProvider. | |
TimeFormat | Enumeration of time formats. | |
ToolbarItem | Describes toolbar item. | Deprecated |
TreeDataProvider | Type definition for all Tree data providers | |
TreeDataProviderMethod | Signature for a method that returns TreeDataProviderPromise for supplied parent node | |
TreeDataProviderPromise | A Promise for TreeDataProviderRaw | |
TreeDataProviderRaw | Array of tree node data elements | |
TreeModelNodeType | Type definition of all tree model nodes. | |
TreeNodeEditorRenderer | Type for tree node editor renderer. | |
TreeNodeItemData | Type definition of tree node item data. |
Last Updated: 19 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.