PropertyFilterBuilderRuleValueRendererProps Interface

Props for custom PropertyFilterBuilderRuleValue renderer.

Extends

Properties

Name Type Description
operator PropertyFilterBuilderRuleOperator Current operator.  

Inherited properties

Name Type Inherited from Description
editorSystem Inherited "legacy" | "new" PropertyFilterBuilderRuleValueProps Specifies which editors system should be used: legacy or the new one.
onChange Inherited (value: PropertyValue) => void PropertyFilterBuilderRuleValueProps Callback that is invoked when value changes.
property Inherited PropertyDescription PropertyFilterBuilderRuleValueProps Property used in rule to which this value will be compared to.
value Inherited PropertyValue | undefined PropertyFilterBuilderRuleValueProps Currently entered value.

Defined in

Last Updated: 16 May, 2025