PropertyDescription Interface
PropertyDescription contains metadata about a Property
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
converter | PropertyConverterInfo | undefined | Information for a property converter | |
dataController | string | undefined | Get the custom DataController by this name and register it with the property editor | |
displayLabel | string | Display label for the property description | |
editor | PropertyEditorInfo | undefined | Information for a property editor | |
enum | EnumerationChoicesInfo | undefined | Additional information for enumerations | |
hideCompositePropertyLabel | boolean | undefined | Should property label for composite (struct & array) properties be rendered. | |
name | string | Name of the property description | |
renderer | PropertyRendererInfo | undefined | Information for property renderer customization | |
typename | string | Type name used to determine applicable Type Converter and Property Editor |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.