KindOfQuantity Class

A Typescript class representation of a KindOfQuantity.

Extends

Methods

Name Description
constructor(schema: Schema, name: string): KindOfQuantity    
addPresentationFormat(format: Format | OverrideFormat, isDefault: booleanfalse): void Protected    
createFormatOverride(parent: Format, precision?: number, unitLabelOverrides?: [Unit | InvertedUnit, undefined | string][]): OverrideFormat Protected Creates an OverrideFormat in the context of this KindOfQuantity.  
fromJSON(kindOfQuantityProps: KindOfQuantityProps): Promise<void>    
fromJSONSync(kindOfQuantityProps: KindOfQuantityProps): void    
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): KindOfQuantityProps Save this KindOfQuantity's properties to an object for serializing to JSON.  
assertIsKindOfQuantity(item?: SchemaItem): item is KindOfQuantity Static Type assertion to check if the SchemaItem is of type KindOfQuantity.  
isKindOfQuantity(item?: SchemaItem): item is KindOfQuantity Static Type guard to check if the SchemaItem is of type KindOfQuantity.  

Inherited methods

Name Inherited from Description
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited SchemaItem Indicates if the two SchemaItem objects are equal by comparing their respective key properties.
parseFullName(fullName: string): [string, string] Static Inherited SchemaItem Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.

Properties

Name Type Description
_persistenceUnit Protected LazyLoadedUnit | LazyLoadedInvertedUnit    
_presentationFormats Protected Format | OverrideFormat[]    
_relativeError Protected number    
defaultPresentationFormat Accessor ReadOnly undefined | Format | OverrideFormat The first presentation format in the list of Formats.  
persistenceUnit Accessor undefined | LazyLoadedUnit | LazyLoadedInvertedUnit    
presentationFormats Accessor ReadOnly Format | OverrideFormat[] A list of presentation formats.  
relativeError Accessor ReadOnly number    
schemaItemType Accessor Static ReadOnly SchemaItemType Get the type of item represented by this class  
schemaItemType Readonly SchemaItemType Get the type of item represented by this instance  

Inherited properties

Name Type Inherited from Description
_description Protected Inherited string | undefined SchemaItem  
_key Protected Inherited SchemaItemKey SchemaItem  
_label Protected Inherited string | undefined SchemaItem  
description Accessor Inherited ReadOnly undefined | string SchemaItem  
fullName Accessor Inherited ReadOnly string SchemaItem  
key Accessor Inherited ReadOnly SchemaItemKey SchemaItem  
label Accessor Inherited ReadOnly undefined | string SchemaItem  
name Accessor Inherited ReadOnly string SchemaItem  
schema Readonly Inherited Schema SchemaItem  

Defined in

Last Updated: 21 February, 2025