SchemaItem Class

An abstract class that supplies all of the common parts of a SchemaItem.

Extended by

Methods

Name Description
constructor(schema: Schema, name: string): SchemaItem    
fromJSON(schemaItemProps: SchemaItemProps): Promise<void>    
fromJSONSync(schemaItemProps: SchemaItemProps): void    
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): SchemaItemProps Save this SchemaItem's properties to an object for serializing to JSON.  
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Indicates if the two SchemaItem objects are equal by comparing their respective key properties.  
parseFullName(fullName: string): [string, string] Static Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.  

Properties

Name Type Description
_description Protected string | undefined    
_key Protected SchemaItemKey    
_label Protected string | undefined    
description Accessor ReadOnly undefined | string    
fullName Accessor ReadOnly string    
key Accessor ReadOnly SchemaItemKey    
label Accessor ReadOnly undefined | string    
name Accessor ReadOnly string    
schema Readonly Schema    
schemaItemType Accessor Abstract ReadOnly SchemaItemType Get the type of item represented by this instance  
schemaItemType Accessor Static ReadOnly SupportedSchemaItemType Get the type of item represented by this class  

Defined in

Last Updated: 21 February, 2025