Format Class

Extends

Methods

Name Description
constructor(schema: Schema, name: string): Format    
addUnit(unit: Unit | InvertedUnit, label?: string): void Protected Adds a Unit, or InvertedUnit, with an optional label override.  
fromJSON(formatProps: SchemaItemFormatProps): Promise<void>    
fromJSONSync(formatProps: SchemaItemFormatProps): void    
hasFormatTrait(formatTrait: FormatTraits): boolean    
setPrecision(precision: number): void Protected    
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): SchemaItemFormatProps Save this Format's properties to an object for serializing to JSON.  
assertIsFormat(item?: SchemaItem): item is Format Static Type assertion to check if the SchemaItem is of type Format.  
isFormat(item?: SchemaItem): item is Format Static Type guard to check if the SchemaItem is of type Format.  

Inherited methods

Name Inherited from Description
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited SchemaItem Indicates if the two SchemaItem objects are equal by comparing their respective key properties.
parseFullName(fullName: string): [string, string] Static Inherited SchemaItem Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings.

Properties

Name Type Description
_base Protected BaseFormat    
_units Protected [Unit | InvertedUnit, undefined | string][] | undefined    
decimalSeparator Accessor ReadOnly string    
formatTraits Accessor ReadOnly FormatTraits    
includeZero Accessor ReadOnly undefined | boolean    
minWidth Accessor ReadOnly undefined | number    
precision Accessor ReadOnly DecimalPrecision | FractionalPrecision    
roundFactor Accessor ReadOnly number    
schemaItemType Accessor Static ReadOnly SchemaItemType Get the type of item represented by this class  
schemaItemType Readonly SchemaItemType Get the type of item represented by this instance  
scientificType Accessor ReadOnly undefined | ScientificType    
showSignOption Accessor ReadOnly ShowSignOption    
spacer Accessor ReadOnly undefined | string    
stationOffsetSize Accessor ReadOnly undefined | number    
stationSeparator Accessor ReadOnly string    
thousandSeparator Accessor ReadOnly string    
type Accessor ReadOnly FormatType    
units Accessor ReadOnly undefined | [Unit | InvertedUnit, undefined | string][]    
uomSeparator Accessor ReadOnly string    

Inherited properties

Name Type Inherited from Description
_description Protected Inherited string | undefined SchemaItem  
_key Protected Inherited SchemaItemKey SchemaItem  
_label Protected Inherited string | undefined SchemaItem  
description Accessor Inherited ReadOnly undefined | string SchemaItem  
fullName Accessor Inherited ReadOnly string SchemaItem  
key Accessor Inherited ReadOnly SchemaItemKey SchemaItem  
label Accessor Inherited ReadOnly undefined | string SchemaItem  
name Accessor Inherited ReadOnly string SchemaItem  
schema Readonly Inherited Schema SchemaItem  

Defined in

Last Updated: 21 February, 2025