StatusBar
Classes for defining a StatusBar
Classes
Name | Description | |
---|---|---|
StatusBarWidgetControl | Status Bar Widget Control. | Deprecated |
TileLoadingIndicator | TileLoadingIndicator React component | |
ViewAttributesStatusField | Widget for showing Checkboxes for View Attributes |
Enumerations
Name | Description | |
---|---|---|
StatusBarLabelSide | Defines which side of Icon where label is placed | |
StatusBarSection | Status bar Groups/Sections from Left to Right |
Global Functions
Name | Description | |
---|---|---|
isStatusBarActionItem | StatusBarActionItem type guard. | |
isStatusBarCustomItem | StatusBarCustomItem type guard. | |
isStatusBarLabelItem | StatusBarLabelItem type guard. | |
SectionsStatusField | Status Field for showing section extra tools for clearing and showing manipulators | |
SelectionCountField | Status field component used to display the number of selected items. | |
SelectionInfoField | SelectionInfoField component is designed to be specified in a status bar. |
Deprecated |
SelectionScopeField | SelectionScopeField component is designed to be specified in a status bar. |
|
SnapModeField | SnapModeField component designed to be specified in a status bar. |
|
StatusBar | Status Bar React component. | Deprecated |
StatusBarCenterSection | StatusBar Center Section React functional component | |
StatusBarComposer | Component to load components into the StatusBar. | |
StatusBarDialog | Dialog component used in a StatusBarIndicator component. | |
StatusBarDialogTitleBar | Dialog component used in a StatusBarDialog component. | |
StatusBarDialogTitleBarButton | Dialog component used in a StatusBarDialog component. | |
StatusBarField | Field component used in StatusBar component. | Deprecated |
StatusBarIndicator | General-purpose StatusBar indicator. | Deprecated |
StatusBarLabelIndicator | StatusBar indicator that shows a label with an icon. | Deprecated |
StatusBarLeftSection | StatusBar Left Section React functional component | |
StatusBarPopover | Popover component used in StatusBar component. |
|
StatusBarPopup | Popup component used in StatusBar component. | Deprecated |
StatusBarRightSection | StatusBar Right Section React functional component | |
StatusBarSeparator | Component used to separate status fields in a status bar. | |
StatusBarSpaceBetween | StatusBar With Space Between Items React functional component | |
useDefaultStatusBarItems | Hook that returns items from StatusBarItemsManager. | Deprecated |
useSelectionSetSize | React hook that returns element count of a selection set. | |
useUiItemsProviderBackstageItems | Hook that returns backstage items from UiItemsManager. | Deprecated |
useUiItemsProviderStatusBarItems | Hook that returns items from StatusBarItemsManager. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
CommonStatusBarItem | Describes the data needed to insert a button into the status bar. | |
SectionsStatusFieldProps | Sections Status Field Props | |
SelectionCountFieldProps | Properties for the SelectionCountField component. | |
StatusBarActionItem | Describes the data needed to insert an action item into the status bar. | |
StatusBarComposerProps | Properties for the StatusBarComposer React components | Deprecated |
StatusBarCustomItem | Describes the data needed to insert an item into the StatusBar. | |
StatusBarDialogProps | Properties of StatusBarDialog component. | |
StatusBarDialogTitleBarButtonProps | Properties of StatusBarDialogTitleBarButton component. | |
StatusBarDialogTitleBarProps | Properties of StatusBarDialogTitleBar component. | |
StatusBarFieldProps | Properties of StatusBarField component. | Deprecated |
StatusBarIndicatorProps | Properties of StatusBarIndicator component. | Deprecated |
StatusBarLabelIndicatorProps | Properties of StatusBarLabelIndicator component. | Deprecated |
StatusBarLabelItem | Describes the data needed to insert a label item with an optional icon into the status bar. | |
StatusBarProps | Properties for the StatusBar React component | Deprecated |
UseSelectionSetSizeArgs | Arguments for useSelectionSetSize hook. |
Namespaces
Name | Description | |
---|---|---|
StatusBar | Components used in a StatusBar. | Deprecated |
StatusBarDialog | Components used in a StatusBarDialog. | |
StatusBarItemUtilities | Utility functions for creating and maintaining StatusBar items. | |
StatusBarPopover | Components used in StatusBarPopover . |
Type Aliases
Name | Description | |
---|---|---|
StatusBarFieldId | Status Bar Field type. | Deprecated |
StatusBarItem | Describes the data needed to insert a button into the status bar. |
Last Updated: 08 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.