core-bentley
Classes
Name | Description | |
---|---|---|
AbandonedError | ||
BeDuration | A duration of time. | |
BeEvent | Manages a set of listeners for a particular event and notifies them when the event is raised. | |
BeEventList | A list of BeEvent objects, accessible by an event name. | |
BentleyError | Base exception class for iTwin.js exceptions. | |
BeTimePoint | A specific point in time relative to the current time. | |
BeUiEvent | Specialization of BeEvent for events that take a single strongly typed argument, primarily used for UI events. | |
ByteStream | Allows the contents of an ArrayBuffer | |
Dictionary | Maintains a mapping of keys to values. | |
DisposableList | A disposable container of disposable objects. | |
Entry | An entry holds the key and value, and pointers to any older and newer entries. | |
IndexedValue | Associates a value of type T with an index representing its insertion order in an IndexMap |
|
IndexMap | Maintains a set of unique elements in sorted order and retains the insertion order of each. | |
Logger | Logger allows libraries and apps to report potentially useful information about operations, and it allows apps and users to control | |
LRUCache | A mapping of a key/value pairs, where the size of the cache can be limited. | |
LRUDictionary | A LRUCache using a Dictionary as its internal storage, permitting custom key comparison logic. | |
LRUMap | A LRUCache using a standard Map as its internal storage. | |
MutableCompressedId64Set | A mutable set of valid Id64Strings sorted in ascending order by the 64-bit unsigned integer value of the Ids. | |
ObservableSet | A standard Set |
|
OneAtATimeAction | Orchestrator of a one-at-a-time activity. | |
OrderedId64Array | A SortedArray of unique Id64Strings sorted in ascending order by the 64-bit unsigned integer values of the Ids. | |
OrderedSet | A mutable ReadonlyOrderedSet. | |
PerfLogger | Simple performance diagnostics utility. | |
PriorityQueue | A priority queue implemented as a heap array. | |
ProcessDetector | Functions to determine the type of JavaScript process currently executing. | |
ReadonlyOrderedSet | A read-only equivalent of Set<T> that maintains its elements in sorted order as specified by a comparison function. |
|
ReadonlySortedArray | A read-only view of an array of some type T sorted according to some user-supplied criterion. | |
SortedArray | Maintains an array of some type T in sorted order. | |
StopWatch | A StopWatch for timing operations. | |
Tracing | Enables OpenTelemetry tracing in addition to traditional logging. | Deprecated |
TransientIdSequence | Generates unique Id64String values in sequence, which are guaranteed not to conflict with Ids associated with persistent elements or models. | |
TupleKeyedMap | A map similar to the standard JavaScript Map collection except that the keys must be a tuple | |
TypedArrayBuilder | Incrementally builds a TypedArray of unsigned 8-, 16-, or 32-bit integers. | |
Uint16ArrayBuilder | A TypedArrayBuilder for producing a Uint16Array. | |
Uint32ArrayBuilder | A TypedArrayBuilder for producing a Uint32Array. | |
Uint8ArrayBuilder | A TypedArrayBuilder for producing a Uint8Array. | |
UintArrayBuilder | A TypedArrayBuilder that can populate a UintArray with the minimum | |
UnexpectedErrors | Utility for handling/reporting unexpected runtime errors. | |
YieldManager | Provides a mechanism by which a loop can be made to periodically yield control back to the browser/node environment. |
Enumerations
Name | Description | |
---|---|---|
BentleyLoggerCategory | Logger categories used by this package | |
BentleyStatus | Standard status code. | |
BriefcaseStatus | Error statuses produced by various briefcase operations, typically encountered as the errorNumber of an IModelError. |
|
ChangeSetStatus | Error statuses produced by various Changeset operations, typically encountered as the errorNumber of an IModelError. |
|
DbOpcode | Values, stored in changesets, that indicate what operation was performed on the database. | |
DbResult | Values for return codes from BeSQLite functions. | |
DuplicatePolicy | Describes how duplicate values are handled when inserting into a SortedArray. | |
GeoServiceStatus | GeoServiceStatus errors | |
HttpStatus | Status from returned HTTP status code | |
IModelHubStatus | Statuses produced by APIs that interact with iModelHub, typically encountered as the errorNumber of an IModelError. |
|
IModelStatus | Status codes that are used in conjunction with BentleyError. | |
LogLevel | Use to categorize logging messages by severity. | |
OpenMode | Whether to open a database readonly or writeable. | |
RpcInterfaceStatus | RpcInterface status codes | |
SpanKind | Mirrors the SpanKind enum from @opentelemetry/api | Deprecated |
Global Functions
Name | Description | |
---|---|---|
areEqualPossiblyUndefined | Compare two possibly-undefined values for equality. | |
asInstanceOf | Cast obj to an instance of class T , or return undefined if obj is not an instance of class T . |
|
assert | Asserts that a condition is true and - when enabled - throws an error if it is not. |
|
base64StringToUint8Array | Given a base-64-encoded string, decode it into an array of bytes. | |
compareBooleans | ||
compareBooleansOrUndefined | ||
compareNumbers | ||
compareNumbersOrUndefined | ||
comparePossiblyUndefined | ||
compareStrings | ||
compareStringsOrUndefined | ||
compareWithTolerance | An OrderedComparator for numbers that treats two numbers as equal if the absolute value of their difference is less than a specified tolerance. | |
dispose | Convenience function for disposing of a disposable object that may be undefined. | |
disposeArray | Disposes of and empties a list of disposable objects. | |
isIDisposable | A type guard that checks whether the given argument implements IDisposable interface |
|
isInstanceOf | Returns true if obj is an object of class T . |
|
isProperSubclassOf | Check if class subclass is a different class from superclass but extends from superclass |
|
isSubclassOf | Check if class subclass is superclass or extends from superclass |
|
lowerBound | Given a sorted array, computes the position at which the specified value should be inserted into the array so that the array remains sorted. | |
omit | A runtime property omitter, makes a shallow copy of the given object without the specified properties | |
partitionArray | Partitions an array in-place according to some criterion, such that elements that fulfill the criterion are grouped in the lower | |
shallowClone | A CloneFunction that, given a value of type T, returns the same value. | |
using | A 'using' function which is a substitution for .NET's using statement. | |
utf8ToString | Given an array of bytes containing a utf-8 string, convert to a string. |
Interfaces
Name | Description | |
---|---|---|
DictionaryEntry | Represents an entry in a Dictionary. | |
EntryContainer | The interface that must be satisfied by the underlying container type used by a LRUCache. | |
IDisposable | Interface adopted by a type which has deterministic cleanup logic. | |
JSONSchema | ||
JSONSchemaMap | ||
JSONSchemaSnippet | ||
LoggerCategoryAndLevel | Identifies a logging category and the LogLevel that should be used for it. | |
LoggerLevelsConfig | Specifies logging levels, including the default logging level and a set of categories and levels for them. | |
TransientIdSequenceProps | JSON representation of a TransientIdSequence, primarily useful for transferring sequences to and from a Worker. | |
TypedArrayBuilderOptions | Options used to construct a TypedArrayBuilder. | |
UintArrayBuilderOptions | Options used to construct a UintArrayBuilder. | |
YieldManagerOptions | Options supplied to a YieldManager. |
Namespaces
Name | Description | |
---|---|---|
CompressedId64Set | A compact string representation of an Id64Set. | |
Guid | The Guid namespace provides facilities for working with GUID strings using the "8-4-4-4-12" pattern. | |
Id64 | The Id64 namespace provides facilities for working with 64-bit identifiers. | |
JsonUtils | Utility functions for converting from JSON objects, with default values. | |
OrderedId64Iterable | A collection of valid Id64Strings sorted in ascending order by the unsigned 64-bit integer value of the Ids. |
Type Aliases
Name | Description | |
---|---|---|
AccessToken | A string representing a token used to access resources. | |
AsyncFunction | Any function returning a Promise. | |
AsyncMethodsOf | Extracts the names of all function properties of T that return a Promise. |
|
CloneFunction | A function that, given a value of type T, returns a copy of that value. | |
CompressedId64Set | ||
ComputePriorityFunction | ||
Constructor | Generically represents a class T , for use in type annotations. |
|
DisposeFunc | A definition of function which may be called to dispose an object | |
GetMetaDataFunction | A function that returns a metadata object for a BentleyError. | |
GuidString | A string containing a well-formed string representation of a Guid. | |
Id64Arg | Used as an argument to a function that can accept one or more Id64Strings. | |
Id64Array | An array of Id64Strings. | |
Id64Set | A set of Id64Strings. | |
Id64String | A string containing a well-formed string representation of an Id64. | |
JSONSchemaType | ||
JSONSchemaTypeName | ||
Listener | A function invoked when a BeEvent is raised. | |
ListenerType | Retrieves the type of the callback function for an event type like BeEvent. | |
LogFunction | Defines the signature for a log function. | |
LoggingMetaData | Optional metadata attached to a BentleyError. | |
MarkRequired | Make a new type from an existing type T , with set of optional properties K required. |
|
MaybePromise | A type that is either T or Promise<T> . |
|
Mutable | The inverse of TypeScript's ReadonlyT with any readonly modifiers removed. |
|
NonFunctionPropertiesOf | Produces a type consisting of all of the public properties of T except for those of type function . |
|
NonFunctionPropertyNamesOf | Extracts the names of all public properties of T that are not of type function . |
|
OnUnexpectedError | A function to be notified when an unexpected error happens | |
Optional | Make a new type from an existing type T , with set of required properties K optional. |
|
OrderedComparator | A function that returns a numerical value indicating how two objects are ordered in relation to one another. | |
OrderedId64Iterable | ||
PickAsyncMethods | The members of T that are async functions (functions that return a promise), and no other properties |
|
PickMethods | The members of T that are functions and no other properties |
|
PickSyncMethods | The members of T that are functions that do not return a Promise |
|
PromiseReturnType | Extracts the type to which the Promise returned by an async function resolves. | |
RemapTransientLocalId | A function returned by TransientIdSequence.merge that remaps the local Id portion of an Id64String generated by | |
RequireAtLeastOne | Defines a type wherein at least one of the properties of T is required to exist. | |
StatusCategoryHandler | ||
UintArray | A TypedArray containing unsigned 8-, 16-, or 32-bit integers. |
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.