PerfLogger Class
Simple performance diagnostics utility. It measures the time from construction to disposal. On disposal it logs the routine name along with the duration in milliseconds. It also logs the routine name at construction time so that nested calls can be disambiguated.
The timings are logged using the log category Performance and log severity LogLevel.INFO. Enable those, if you want to capture timings.
Implements
- Disposable
Methods
Name | Description | |
---|---|---|
constructor(operation: string, metaData?: LoggingMetaData): PerfLogger | ||
[dispose](): void | ||
dispose(): void | Deprecated |
Defined in
- core/bentley/src/Logger.ts Line 333
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.