ElementGeometry

Classes for defining the symbology and geometry of geometric elements

Global Functions

Name Description  
computeGraphemeOffsets Computes the range from the start of a RunLayoutResult to the trailing edge of each grapheme.  
computeLayoutTextBlockResult Gets the result of laying out the the contents of a TextBlock into a series of lines containing runs.  
produceTextAnnotationGeometry Produce a geometric representation of a text annotation, with the annotation's anchor point at the origin.  

Interfaces

Name Description  
ComputeGraphemeOffsetsArgs Arguments supplied to computeGraphemeOffsets.  
CreateFontFileFromShxBlobArgs Arguments supplied to createFromShxFontBlob.  
FontFile A container for one or more font faces, often originating as a file on disk.  
LayoutTextBlockArgs Arguments supplied to computeLayoutTextBlockResult.  
ProduceTextAnnotationGeometryArgs Arguments supplied to produceTextAnnotationGeometry.  

Namespaces

Name Description  
FontFile  
LineStyleDefinition A line style definition is a uniquely named pattern that repeats as it is displayed along a curve path.  

Last Updated: 20 December, 2024