computeGraphemeOffsets Function

Computes the range from the start of a RunLayoutResult to the trailing edge of each grapheme. It is the responsibility of the caller to determine the number and character indexes of the graphemes.

computeGraphemeOffsets(args: ComputeGraphemeOffsetsArgs): Range2d[]

@returns If the RunLayoutResult's source is a TextRun, it returns an array containing the range of each grapheme. Otherwise, it returns and empty array.

Parameter Type Description
args ComputeGraphemeOffsetsArgs  

Returns - Range2d[]

If the RunLayoutResult's source is a TextRun, it returns an array containing the range of each grapheme. Otherwise, it returns and empty array.

Defined in

Last Updated: 21 November, 2024