TextRun Class
The most common type of Run, containing a sequence of characters to be displayed using a single style.
Extends
Methods
Name | Description | |
---|---|---|
clone(): TextRun | Create a deep copy of this component. | |
equals(other: TextBlockComponent): boolean | Returns true if this is equivalent to other . |
|
stringify(): string | Simply returns content. | |
toJSON(): TextRunProps | Convert this component to its JSON representation. | |
create(props: Omit<TextRunProps, "type">): TextRun Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyStyle(styleName: string, options?: ApplyTextStyleOptions): void Inherited | TextBlockComponent | Apply the TextStyle specified by styleName to this component, optionally preserving styleOverrides and/or preventing propagation to sub-components. |
clearStyleOverrides(): void Inherited | TextBlockComponent | Reset any styleOverrides applied to this component's TextStyle. |
Properties
Name | Type | Description | |
---|---|---|---|
baselineShift | BaselineShift | Whether to display content as a subscript, superscript, or normally. | |
content | string | The sequence of characters to be displayed by the run. | |
type Readonly | "text" | Discriminator field for the Run union. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
overridesStyle Accessor Inherited ReadOnly | boolean | TextBlockComponent | Returns true if styleOverrides specifies any deviations from this component's base TextStyle. |
styleName Accessor Inherited | string | TextBlockComponent | The name of the TextStyle that provides the base formatting for the contents of this component. |
styleOverrides Accessor Inherited | TextStyleSettingsProps | TextBlockComponent | Deviations in individual properties of the TextStyle specified by styleName. For example, if the style uses the "Arial" font, you can override that by settings styleOverrides.fontName to "Comic Sans". |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.