ExportGraphics
APIs for producing low-level graphics primitives from element geometry.
Classes
Name | Description | |
---|---|---|
ExportGraphicsMeshVisitor | * Iterator to walk the facets of an ExportGraphicsMesh and present them to the world as if visiting a Polyface. |
Interfaces
Name | Description | |
---|---|---|
ExportGraphicsInfo | Info provided to ExportGraphicsFunction about graphics. | |
ExportGraphicsLines | A collection of line segments, suitable for direct use with graphics APIs. | |
ExportGraphicsMesh | A triangulated mesh with unified indices, suitable for direct use with graphics APIs. | |
ExportGraphicsOptions | Parameters for IModelDb.exportGraphics | |
ExportLinesInfo | Info provided to ExportLinesFunction about linework graphics. | |
ExportPartDisplayInfo | Information about the base display properties when a GeometryPart was | |
ExportPartGraphicsOptions | Parameters for IModelDb.exportPartGraphics | |
ExportPartInfo | Info provided to ExportPartFunction about graphics. | |
ExportPartInstanceInfo | Information about references to GeometryPart elements found during | |
ExportPartLinesInfo | Info provided to ExportPartFunction about line graphics. |
Namespaces
Name | Description | |
---|---|---|
ExportGraphics | Provides utility functions for working with data generated by IModelDb.exportGraphics |
Type Aliases
Name | Description | |
---|---|---|
ExportGraphicsFunction | A callback function that receives generated graphics. | |
ExportLinesFunction | A callback function that receives generated line graphics. | |
ExportPartFunction | A callback function that receives generated graphics for a GeometryPart. | |
ExportPartLinesFunction | A callback function that receives generated line graphics for a GeometryPart. |
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.