exportPartGraphics Method
Exports meshes suitable for graphics APIs from a specified GeometryPart in this IModelDb. The expected use case is to call IModelDb.exportGraphics and supply the optional partInstanceArray argument, then call this function for each unique GeometryPart from that list.
- The results of changing ExportPartGraphicsOptions during the ExportPartGraphicsOptions.onPartGraphics callback are not defined.
- See export-gltf under test-apps in the iTwin.js monorepo for a working reference.
exportPartGraphics(exportProps: ExportPartGraphicsOptions): DbResult
@returns 0 is successful, status otherwise
Parameter | Type | Description |
---|---|---|
exportProps | ExportPartGraphicsOptions |
Returns - DbResult
0 is successful, status otherwise
Defined in
- core/backend/src/IModelDb.ts Line 1338
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.