BeEventList<T extends Listener> Class
A list of BeEvent objects, accessible by an event name. This class may be used instead of explicitly declaring each BeEvent as a member of a containing class.
Methods
Name | Description | |
---|---|---|
constructor<T extends Listener>(): BeEventList<T> | ||
get(name: string): BeEvent<T> | Gets the event associated with the specified name, creating the event if it does not already exist. | |
remove(name: string): void | Removes the event associated with a name. |
Defined in
- core/bentley/src/BeEvent.ts Line 149
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.