EntryContainer<K, V> Interface
The interface that must be satisfied by the underlying container type used by a LRUCache. Compatible with a Dictionary or a standard Map.
Methods
Name | Description | |
---|---|---|
clear(): void | ||
delete(key: K): void | ||
get(key: K): undefined | Entry<K, V> | ||
has(key: K): boolean | ||
set(key: K, value: Entry<K, V>): void |
Properties
Name | Type | Description | |
---|---|---|---|
size Readonly | number |
Defined in
- core/bentley/src/LRUMap.ts Line 74
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.