Constant Class
A Constant is a specific type of Unit that represents a number.
Extends
Methods
Name | Description | |
---|---|---|
constructor(schema: Schema, name: string): Constant | ||
fromJSON(constantProps: ConstantProps): Promise<void> | ||
fromJSONSync(constantProps: ConstantProps): void | ||
toJSON(standalone: booleanfalse, includeSchemaVersion: booleanfalse): ConstantProps | Save this Constants properties to an object for serializing to JSON. | |
assertIsConstant(item?: SchemaItem): item is Constant Static | Type assertion to check if the SchemaItem is of type Constant. | |
isConstant(item?: SchemaItem): item is Constant Static | Type guard to check if the SchemaItem is of type Constant. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
equalByKey(thisSchemaItem: SchemaItem, thatSchemaItemOrKey?: SchemaItemKey | SchemaItem): boolean Static Inherited | SchemaItem | Indicates if the two SchemaItem objects are equal by comparing their respective key properties. |
parseFullName(fullName: string): [string, string] Static Inherited | SchemaItem | Parses the given full name, {schemaName}.{schemaItemName} or {schemaName}:{schemaItemName}, into two separate strings. |
Properties
Name | Type | Description | |
---|---|---|---|
_definition Protected | string | ||
_denominator Protected | number | undefined | ||
_numerator Protected | number | undefined | ||
_phenomenon Protected | LazyLoadedPhenomenon | undefined | ||
definition Accessor ReadOnly | string | ||
denominator Accessor ReadOnly | number | ||
hasDenominator Accessor ReadOnly | boolean | ||
hasNumerator Accessor ReadOnly | boolean | ||
numerator Accessor ReadOnly | number | ||
phenomenon Accessor ReadOnly | undefined | LazyLoadedPhenomenon | ||
schemaItemType Accessor Static ReadOnly | SchemaItemType | Get the type of item represented by this class | |
schemaItemType Readonly | SchemaItemType | Get the type of item represented by this instance |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_description Protected Inherited | string | undefined | SchemaItem | |
_key Protected Inherited | SchemaItemKey | SchemaItem | |
_label Protected Inherited | string | undefined | SchemaItem | |
description Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
fullName Accessor Inherited ReadOnly | string | SchemaItem | |
key Accessor Inherited ReadOnly | SchemaItemKey | SchemaItem | |
label Accessor Inherited ReadOnly | undefined | string | SchemaItem | |
name Accessor Inherited ReadOnly | string | SchemaItem | |
schema Readonly Inherited | Schema | SchemaItem |
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.