OverrideFormat Class
Overrides of a Format, from a Schema, and is SchemaItem that is used specifically on KindOfQuantity.
Methods
Name | Description | |
---|---|---|
getFormatProps(): SchemaItemOverrideFormatProps | Returns a JSON object that contains the specification for the OverrideFormat where the precision and units properties have been overriden. | |
hasFormatTrait(formatTrait: FormatTraits): boolean | ||
createOverrideFormatFullName(parent: Format, precision?: DecimalPrecision | FractionalPrecision, unitAndLabels?: [LazyLoadedUnit | LazyLoadedInvertedUnit, undefined | string][]): string Static | Creates a valid OverrideFormat fullName from the parent Format and overridden units. | |
parseFormatString(formatString: string): OverrideFormatProps Static | Parses the format string into the parts that make up an Override Format |
Properties
Name | Type | Description | |
---|---|---|---|
decimalSeparator Accessor ReadOnly | string | ||
formatTraits Accessor ReadOnly | FormatTraits | ||
fullName Accessor ReadOnly | string | ||
includeZero Accessor ReadOnly | undefined | boolean | ||
minWidth Accessor ReadOnly | undefined | number | ||
name Readonly | string | The name of this OverrideFormat. | |
parent Readonly | Format | The Format that this OverrideFormat is extending | |
precision Accessor ReadOnly | DecimalPrecision | FractionalPrecision | ||
roundFactor Accessor ReadOnly | number | ||
scientificType Accessor ReadOnly | undefined | ScientificType | ||
showSignOption Accessor ReadOnly | ShowSignOption | ||
spacer Accessor ReadOnly | undefined | string | ||
stationOffsetSize Accessor ReadOnly | undefined | number | ||
stationSeparator Accessor ReadOnly | string | ||
thousandSeparator Accessor ReadOnly | string | ||
type Accessor ReadOnly | FormatType | ||
units Accessor ReadOnly | undefined | ReadonlyArray<[LazyLoadedUnit | LazyLoadedInvertedUnit, undefined | string]> | ||
uomSeparator Accessor ReadOnly | string |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.