TextareaPropertyEditor Class

Textarea Property Editor registered for the "text" and "string" type names and "multi-line" editor name. It uses the TextareaEditor React component.

Extends

Methods

Name Description
constructor(): TextareaPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void Inherited PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  

Properties

Name Type Description
containerHandlesBlur Accessor ReadOnly boolean    
containerHandlesEnter Accessor ReadOnly boolean    
containerHandlesTab Accessor ReadOnly boolean    
reactNode Accessor ReadOnly React.ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesEscape Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor Inherited ReadOnly boolean PropertyEditorBase  
customDataController Inherited undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 30 January, 2025