useEditor Function
Custom React hook that returns editor for specified metadata and value. It uses EditorsRegistry
context to find registered editors.
If no registered editor is found, it will use applicable default editor.
useEditor(metadata: ValueMetadata, value: Value): | undefined
Parameter | Type | Description |
---|---|---|
metadata | ValueMetadata | |
value | Value |
Returns - | undefined
Defined in
Last Updated: 17 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.