IMergingPropertyDataProvider Interface
An interface for property data provider which combines any number of IPropertyDataProvider instances.
Methods
Name | Description | |
---|---|---|
getData(): Promise<PropertyData> | Returns merged property data from all source providers. | |
getSourceProviderFromPropertyRecord(record: PropertyRecord): undefined | IPropertyDataProvider | Determines source provider from a given PropertyRecord. |
Properties
Name | Type | Description | |
---|---|---|---|
onDataChanged | PropertyDataChangeEvent | Property data change event that is raised when any of the source providers raise this event. |
Defined in
Last Updated: 17 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.