ToggleEditor Class

ToggleEditor React component that is a property editor with checkbox input

Extends

Implements

Methods

Name Description
componentDidMount(): void Called immediately after a component is mounted.  
componentWillUnmount(): void Called immediately before a component is destroyed.  
getPropertyValue(): Promise<undefined | PropertyValue>    
render(): React.JSX.Element    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly "null" | HTMLElement    
state Readonly Readonly<ToggleEditorState>    

Defined in

Last Updated: 30 January, 2025