ToolbarButtonItemProps Interface
Properties of ToolbarButtonItem component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
addGroupSeparator | boolean | undefined | If true add a gap before button. | |
badge | React.ReactNode | undefined | A badge to draw. | |
groupPriority | number | undefined | value added to DOM element as a data attribute | |
icon | React.ReactNode | undefined | button icon. | |
isActive | boolean | undefined | Describes if item is active. | |
isDisabled | boolean | undefined | Describes if the item is disabled. | |
itemPriority | number | undefined | value added to DOM element as a data attribute, shows 0 is undefined | |
onClick | () => void | undefined | Function called when the item is clicked. | |
onKeyDown | (e: React.KeyboardEvent<Element>) => void | undefined | Function called when a key is pressed. | |
providerId | string | undefined | value added to DOM element as a data attribute to hold name of items provider. | |
title | string | Title for the item. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.