ImageCheckBoxEditor Class

ImageCheckBoxEditor Boolean editor that renders with an image instead of checkbox

Extends

Implements

Methods

Name Description
componentDidMount(): void Called immediately after a component is mounted.  
componentWillUnmount(): void Called immediately before a component is destroyed.  
getPropertyValue(): Promise<undefined | PropertyValue>    
render(): React.JSX.Element    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly "null" | HTMLElement    
state Readonly Readonly<ImageCheckBoxEditorState>    

Defined in

Last Updated: 30 January, 2025