TogglePropertyEditor Class

Toggle Property Editor registered for the "bool" and "boolean" type names and "toggle" editor name. It uses the ToggleEditor React component.

Extends

Methods

Name Description
constructor(): TogglePropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void Inherited PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> Inherited PropertyEditorBase  

Properties

Name Type Description
containerHandlesBlur Accessor ReadOnly boolean    
reactNode Accessor ReadOnly React.ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesEnter Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor Inherited ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor Inherited ReadOnly boolean PropertyEditorBase  
customDataController Inherited undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 30 January, 2025