NonPrimitivePropertyLabelRendererProps Interface
Properties for the NonPrimitivePropertyLabelRenderer React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isExpanded | boolean | ||
onCollapse | () => void | ||
onExpand | () => void |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
children | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | PrimitivePropertyLabelRendererProps | Label to be rendered |
className | string | undefined | PrimitivePropertyLabelRendererProps | Additional class name for the label wrapper |
offset | number | undefined | PrimitivePropertyLabelRendererProps | Offset from the left side in pixels. |
renderColon | boolean | undefined | PrimitivePropertyLabelRendererProps | Indicates whether to render a colon after the label |
tooltip | string | undefined | PrimitivePropertyLabelRendererProps | Custom tooltip for the component. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.