ParsedInputProps Interface
Deprecated in 4.17.0. Use React.ComponentProps<typeof ParsedInput>
Props for ParsedInput control
Extends
Properties
Name | Type | Description | |
---|---|---|---|
formatValue | (value: number) => string | Function used to format the value | |
initialValue | number | InitialValue which is used to restore input field if ESC is pressed | |
onChange | (newValue: number) => void | undefined | Function to call when value is changed | |
parseString | (stringValue: string) => ParseResults | Function used to parse user input into a value | |
readonly | boolean | undefined | if readonly then only the formatValue function is used. | |
ref | React.Ref<HTMLInputElement> | undefined | Provides ability to return reference to HTMLInputElement |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.