PropertyCategoryBlockProps Interface

Properties for the PropertyCategoryBlock React component

Extends

Properties

Name Type Description
category PropertyCategory Category of the properties  
children React.ReactNode | undefined Content  
highlight HighlightingComponentProps | undefined Properties used for highlighting  
onExpansionToggled (categoryName: string) => void | undefined Callback to when PropertyCategoryBlock gets expended or collapsed  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 20 November, 2024