FilteredPropertyData Interface
Data returned by FilteringPropertyDataProvider
Extends
Properties
Name | Type | Description | |
---|---|---|---|
filteredTypes | FilteredType[] | undefined | Types of objects that were used for filtering. | |
getMatchByIndex | (index: number) => undefined | HighlightInfo | undefined | Function used for getting HighlightInfo by index from all the filtered matches. | |
matchesCount | number | undefined | Shows how many matches were found when filtering data. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categories Inherited | PropertyCategory[] | PropertyData | |
description Inherited | string | undefined | PropertyData | |
label Inherited | PropertyRecord | PropertyData | |
records Inherited | [categoryName: string]: PropertyRecord[] | PropertyData | |
reusePropertyDataState Inherited | boolean | undefined | PropertyData | Should state of existing property data in the component be re-used for this property data |
Defined in
Last Updated: 30 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.